Tape Jam on Rewind

Discussion in 'Video' started by bryan_simpson, Sep 24, 2003.

  1. Hello,

    I have a Canon GL-2, and recently, whenever I try to rewind a tape, the camera jams
    and says "remove tape." This happens after rougly 20 seconds of rewind every time,
    and it is not the tape, because I have tried many different tapes. Has this happened to
    anyone else? Any suggestions are appreciated.

    Bryan
     
  2. Sounds like a faulty camera. Simple as that.

    BTW when you say you have "tried many tapes" I know what you mean in this context, but I hope that you haven't used different brands of tape in your camera for recording.

    Different brands use different lubricants on the tape surface. And if two incompatible tapes are used in the same camera the lubes react. This can damage either the tapes or the camera's internals such as the head. The camera might be fixed with a head clean but the tape could be permanently damaged.
     
  3. Hi,
    I have a GL2 and Ive had the same problem while rewinding the tape. I have used two different brands of tape so maybe thats why its happening. However I've already used a head cleaner and it hasnt fixed the problem. Could I be using the wrong brand of cleaner or do you think its time to send it in for repair?
    Thank You
     

Share This Page