Kodak Easyshare C330: Lens Error: 14

Discussion in 'Mirrorless Digital Cameras' started by julia_murph, Jul 4, 2006.

  1. About a week ago, I accidentally dropped my camera into the water. it was
    underwater for only a few seconds. I got it out, and i took out my SD card,
    and my batteries, and let it dry. I put new batteries into the camera, and i
    turned it on today, and the camera turns on (yay!) but the but it says "Lens
    Error: 14" the lens stays retracted, and then the camera turns off.

    Does anyone have any suggestions for me please? Is there a simple solution to
    the error? Should I get it fixed, or would it be more economical to get a new
    one?

    Thanks,
    Julia
     
  2. Just buy a new one.
     
  3. The cost to repairing almost any point and shoot digtal is usually atleast the cost of buying a new one (if anyone would repair it at all). In any case I would suggest not buying a kodak again they make a pretty poor camera by comparison to other brand in the same price range. There are also cameras that a waterproof up to 6-10 or so with out an extra housing. Pentax makes one, it one of those slim ones optio something or other. That way if it ever happens again your covered.
     
  4. dont loose heart, my daughters camera said the same thing, just this morning, i typed in troubleshooting, lens error 14 and came accross your post, we recharged the batteries and i put them in this am, at last it came on, then said lens error 14, i pushed on the lens, and then pushed around the outside with my thumb (just cause i was po'd) and then i turned the camera on again, and holy crap if the lens didnt come out of the darn thing!
    i too thought it was $150 down the drain (almost enough to make me cry) but for whatever reason, it worked...i hope yours will too
     
  5. Hey guys, thanks for your comments and suggestions. I tried pushing on the lens.. no such luck :( but thanks for your response. I can't really afford a new camera right now, but I'll keep trying :)
     
  6. no way! i started getting this error last week. i tried taking it apart earlier this week but it is nearly impossible to get to the back of the lens because of all the wires and chips that dont want to come off so i had to put it back together. i was looking for a solution to lens error 14 and lens error 22 and i stumbled upon your post. i couldnt find anything on the whole internet about how to fix this so i got so frustrated that i banged the bottom of the camera really really hard into my fist and tried to turn it on again and still the same old thing.... power comes on, lens pops out half way, and nothing. only this time, it came out half way and then i pulled on it really hard to get it out and what do you know? the dang thing is working. i literally just now fixed it one minute ago. so maybe you should try beating it around and pulling on it. what do you have to lose, your camera already doesnt work and a repair would cost more than what you paid for it.
     
  7. Thanks for all of your help guys. The other day I was really mad at my camera, so I hit it really hard, and now it works! Thanks for all of your help, I really appreciate it.
     
  8. I read what happened to each of you, and tried to "hit" my camera to make it work, to no avail. When I would turn on the camera, the lens would barely move out from the body of the camera, but it did move a little. So, finally, I tried something quite simple that worked: I took a sharp knife and VERY CAREFULLY inserted it between the portion of the lens cover that opens and the frame around it. Then, I turned on the camera, and as soon as the lens began to move out of the camera, I helped it along by pulling out on the lens with the knife. It popped out as normal and has worked since. Also, the "Lens error 14" message on the display went away.
     
  9. I teach and the C330 was working one period and not the next. Read this forum and there was a response that said to push in the lens. I did that, heard a light click and now it works again. If it continues, I will put a VERY light film of lubricant on it as a last resort to throwing it away and buying a new one.
     
  10. i'd been having the same problem
    whenever i tried turning on my camera, it said either lens error 14 or lens error 22
    i searched on here and was just about to consider buying a new one since i had been going two months w/ out a working camera.
    then i saw this, and tryed pushing on the lens and hitting it
    & it worked! thank you =]
     
  11. hey guys!
    i read all of them, && eventually got my lens out but it still doesn't work! :( & im sad coz it was a chrissy gift from my mum && now its half bashed from trying to fix it!
    any other ways?

    much love, cozza xo
     
  12. I have a similar problem with my C330, one day I turned on my camera and when I turned it off the lens was stuck out and wont go back into the camera. I have tried pushing it back in but I can't seem to get it back in. It sometimes says lens error: 12, 14, or 22.
     
  13. Jon,

    Have you tried fully charging the batteries or using brand new ones? In my experience (my in-laws camera is a Kodak), low batteries in Kodak cameras can cause a variety of errors, including the ones you describe. Putting the camera on the charger overnight has always fixed the problem.
     
  14. I have a some Duracell rechargable batteries that I use on the camera and I fully charged them and the camera still had the error. I used normal new Duracell batteries I had and still there was an error. It also made a wierd rumbling sound when I pushed on the lens when I tried to put the lens back in.
     
  15. as i read these , i was discouraged, trying to pry, banging, with no luck. believe it or not, i took a can of compressed air " the kind you may use to blow off electrical stuff $3 at walmart" and shot the air around the lens. you guessed it, it worked! hope you experience same. i put a light coating of mx chain lube on lens housing.
     
  16. you put chain oil into the camera?

    Can you make sure you come back and show us the sample images when that stuff drips onto the sensor?
     
  17. OK guys, here's the problem. The movement of the lens is motor driven. When you turn the camera on, the lens moves. The error 12, error 14, and error 22 refer to control stages in the lens movement ( I think error 22 means the lens won't retract). The lens housing and gear mechanism in this camera is plastic. If there is dust, sand, or debris around the lens housing, it may bind the lens when it trys to extend or retract. By banging it, you might work the gears loose or dislodge whatever is binding the lens (same with the "canned air" blowing out the dust). We've purchased a bunch of these cameras for our electricians in the field. Several have come back with this problem. I've taken the case off, and torn the lens assembly apart, only to find the plastic gears have been "buggered up". It's an inexpensive camera. Try to clean around the lens, give it a few slaps, push/pull the lens.... but failing this fix, buy a new one. Good Luck!
    00MEIS-37944384.jpg
     
  18. THANK YOU!My camera showed error 22, pushed/banged/wiggled the lens.. finally just gave in and started working! Saved me a lot of time and money. Grateful
     
  19. I only found this site after my experience and found it humorous. I also had the error 14 message on a C330. It ironically started about 1 week after the 1 year warranty expired. The short story is; luckily we purchase the camera on our credit card which provides extra year on the manufacturers warranty and had it replaced with an upgrade to a C875.

    Anyway I too couldn?t just throw out a $150 camera. I figured I would try to open the lens by force and if I broke it I?m not out anything. I just opened the case and used a small screw driver to force open the lens and behold it works fine! Like Todd mentioned above; if you have the case open and even with the batteries out, watch out for the capacitor! Good luck.
     
  20. I had the same problem. I almost gave up but I read these posts so I tried beating up on it a little. I had the lens error 14 when I would try to turn it on, then the lens error 22 when it would turn back off. I turned my camera on and pulled the lens open with a little knife and it actually started working! I was really excited until I turned it off again, because I still had lens error 22. I have been tapping on it, hitting on it a little, and shaking it...nothing has worked yet. I am trying to decide if I should keep trying or just go ahead and get a new one.
     

Share This Page