D7000 SD Card Issue "Card Err"

Discussion in 'Nikon' started by joe_willmore, Feb 4, 2013.

  1. I was shooting with my Nikon D7000 a week ago and got a "CARD Err" message. Even though I'd been shooting with that particular SD card in the first slot for a while (and had used it previously and reformatted it multiple times), I took the message at face value, turned the selector switch off, and pulled the card, replacing it with a card that is on the Nikon list of approved card (maker, size, etc.), that had been formatted in the camera and I'd shot with previously. Still the same message. Hmm...I thought. Tried another card. Same message. Another card. Same message. Another card....same message. I went through 7 SD cards (all of which had been formatted previously in the camera and had been used multiple times in the camera). 5 of the 7 cards were on the Nikon list of approved d7000 cards. I consulted the d7000 manual. I checked the firmware (yep, I've got the most recent version). I made sure none of the SD cards were write-protected. And no, none of the cards were full.
    Now, a couple of days later, my D7000 acknowledges all of the previously rejected d7000 cards just fine and I did test shots with each card--again, A-okay.
    Does anyone have any advice/theories about what was going on here?
     
  2. ShunCheung

    ShunCheung Administrator

    I can only guess what might have happened. Please monitor your D7000 closely and see whether this problem recurs.
    What could have happened was that some of the electronic contacts between the camera and the cards were oxidized so that the connection was not working. Inserting and removing the SD cards could have removed some of the oxidization so that the connection is good now. But again, that is completely my speculation. There could be other electronic issues in your camera, but hopefully that is not the case.
     
  3. Nikon's sometimes display wonky behavior. Couple of things that can contribute to issues like these are generic batteries, an unseated lens where the contacts do not make a firm connection, a button that is sticky or partially depressed, etc. Chasing down the exact cause can be frustrating. If your firmware somehow becomes slightly corrupted, it may help to reload or re-install it.
     
  4. When the badness happened, you didn't happen to be near a big source of Electronic Interference? A malfunctioning microwave, WiFi meltdown?..... someone testing an EMP?
    Sun Spots or Cosmic Rays.......?
     
  5. Did you in the meantime change battery, Joe?
     
  6. Thanks for the tips. Ann--I did indeed swap out batteries (first I turned off the camera, took the battery out, put it back on and turned the camera back on--no luck). And Robert--totally agree about the lens not being seated as an issue...happened to me a couple of years ago and it took me 20 minutes to figure out what was wrong with my D70. Mike--no EMP (otherwise a host of other electronic items that were on at the time would have been fried). And the wifi was working (b/c I went online to check a couple of forums to see what people said).
    What I suspect may have happened is Shun's response. When looking at the D7000 manual, it says that this message sometimes occurs when contacts are corroded. Now I don't know why that would happen (especially on multiple SD cards). What was weird was that I finally got the error message to disappear when I put in an 8th card (which was a 4 gig card--too small to use frequently). And again, I was shooting away...no problems...then the error message. Now all of the SD cards function fine in this same body. So it's not as if my camera had been gathering dust or had been unused for weeks or been in any situation where I would have suspected oxidation or corrosion to be an issue.
    Thanks to all of you for sharing your thoughts. If it is corroded contacts, I'm not quite sure what I can do to prevent this from happening again (other than take cards in and out repeatedly).
     
  7. Joe, I too suspect the culprit is one of the card contact pins inside the camera. I would suggest removing the cards and looking closely with a flashlight to see if you can spot anything that doesn't look exactly right with one of the contacts.
     
  8. My d7000 offers this error fairly frequently as well.
    Generally, reseating the card makes it go away.
     
  9. It may be that the electronics just got interfered with by an outside influence/interference, resulting in a hung state, and merely the act of changing cards was not enough to get it out of the hung state.
    Any electronic device based on microprocessors is susceptible to some degree of outside electronic interference, resulting in unpredictable behaviour.
    If you suspect that is happening, the best thing to do, to reset the camera back to a known state, is to turn it OFF, remove all the batteries, wait about 15 minutes, put known good batteries back in, and turn it back on. If all the componenets are OK the system should start back up OK. You can take one additional step by executing a system reset which will set all use functions and values back to factory defaults. Check your camera manual for the exact buttons or menu functions to pick for a system reset.
     
  10. I have had this same issue since buying my camera on Dec. 31, 2012. Reseating the card generally alleviates the issue temporarily, but as I shoot wildlife I have missed many a valuable one-time shot. I'm going to take in to the camera shop where I bought it this week to see if they can offer any help.
     
  11. Hey Joe,
    I have had the problem from time to time. As far as I can tell, there is nothing to "trigger" this error. It is sporadic but, happens consistently. The first time it happened, it was with a new card. Naturally, I thought the card was bad. I replaced card with another brand new one and randomly got the same message. I use the Lexar Professional 16GB Professional 400x SDHC UHS-I cards in both slots. RAW Slot 1 and JPEG Slot 2. In my case, slot 1 always gives the error. I have tried a handful of cards, eventually they all error. This makes me thin that the problem lies with the D7000 body :-( If I power down the D7K, removed and re-seat card all is well until next time.
    Firmware is current.
    Jo Byrd, please lets us know what you find out!!
    Thanks
     

Share This Page