Canon 7D error code 30

Discussion in 'Canon EOS' started by bk-shuman, Jun 7, 2010.

  1. A friend has a Canon 7D and she is getting err 30. She has done the on/off and battery out/in thing a few times. It works for a couple of shoots then back to err 30. Any ideas for her? Besides sending it in for repair.
  2. What she's done is what the manual suggests, and the only thing left in what the manual suggests is what you said at the end. And the manual's description of error 30 gives no clue at all as to what sort of problem it may be, which makes it hard to suggest other possible causes.
    I suppose if you want to try a bunch of other things before sending it in, there are some old standby suggestions that sometimes cure other errors: clean all contacts (battery, battery compartment, lens, lens mount, plus flash and flash mount if a flash might be involved), try a different lens, try a different CF card, try reformatting the flash card in the body. My guess is most or all of them won't fix it, but they're all quick and (assuming she or someone she knows has another lens and a second CF card) free, so it may be worth a shot.
    Oh - when you say "battery", did you mean "batteries"? Both the main battery and the lithium button cell need to be removed for a proper reset.
  3. Thanks, Steve. I'll pass along the information. I don't think she removed the lithium.
  4. One lens or has she tried more then one?
    Another thought is the error happening when using a third party lens?
  5. Peter, I am trying to find out, but she went out for a few.
  7. What's your point, Peter? Bryan can't ask the same question on two forums?
  8. Error 30 is a problem with the shutter. Often the shutter is either stuck open or stuck closed. On Canon DSLR's its often stuck open often from using LiveView.
    If its under warranty send it in. if out of warranty, or you lost your sales receipt, then you are looking at $180 plus 40 bucks shipping and anywhere from 3-6 weeks to get it back(closer to the 6 week time)---to replace or repair the shutter mechanism.
    Can you do something yourself? Yeah. Turn off live view permanently. Live view opens the shutter completely, a bit of an un-natural situation for a DSLR with a focal plane shutter. Read up on focal plane shutters on wiki. They are never all the way open. I doubt whether they were completely redeigned to operate in the full open position.
    Then you have two choices.
    I accept no responsiblity for either of these extreme solutions, and its your neck if you decide to do these stupid things without a net.
    The first might damage you camera... of course its already a paper weight, but don't blame me if you REALLY REALLY damage it, as I'm warning you.
    You give it a couple of whacks with your palm to dislodge the stuck shutter. This worked for me. It made this weird noise, and I turned it off, and then back on again and it works again. Then set it for multiple frame and kick off about 60 or so frames to lubricate the shutter mechanism.
    Another choice is to set it for a long exposure,and interrupt the electrical circuit by either opening the battery compartment or pulling the battery. God only knows what this might do besides what you want. But its supposed to give it an electrical jolt from the sudden loss of power to dislodge the open or closed shutter. Its been known to take as many as 15 times the get this to work. Also set it on multple frames then and kick off about 50 framdes to lubricate the shutter.
    Good luck. But I accept no responsibility if your camera becomes a permanent paperweight by trying any of these foolhardy techniques.
  9. Just started happening on my 7D (out of warranty). Lo and behold I've been using Live View recently! Thanks Zarathu though I'm not sure I'll try your 2 dangerous choices though!
  10. I've owned my 7d for approx. 2.5 yrs and shoot youth/HS sports and portrait photography. I started getting error 30 and have never used Liveview. I got the error with two different canon lenses so ruled that out. I originally got the error at the end of a vacation and then again during a paid shoot shortly after getting back. Setting up the night before the paid shoot worked flawlessly without any errors, turned it off for the night and then it occurred on my first test shot with my client. Had to use my old 30D as a backup.
    My firmware was 1.0.0 and decided to try and update to 2.0.3 before dropping it off for repair. No more shutter errors. I've been doing test shots practically every day for 2 weeks now... not a single error. Hope this fixes it permanently!

Share This Page