Jump to content

Z7 autofocus with self timer feature


Recommended Posts

Ok, I’ve searched the threads and no matter how I did it, it kept coming up with no results found. So please, if you can help.


I’ve got a simple question. I setup my Z7 on a tripod, turn on a 10 second timer, focus is on continuous & wide, press the shutter, and the following happens:

I get into the frame of the shot for a self portrait.

Green light blinks and counts down.

Camera takes image.



Am I doing something wrong? Do I have to set something else to have it focus on me? Done it dozens of times and it just doesn’t work. The only way I can get it to do as wanted is to tether it, or snapbridge.



Link to comment
Share on other sites

Wow, your image is great.

Question, did you focus on the chair before you got in frame?


Like I said, mine just won’t refocus.


Did some more experiments. I have an image of my daughter that it will track all over the screen. Locks eyes and everything, so yes, eye and face tracking works when holding AF-On. You made a good point so I had to test that.


Now, I turn on the self timer, and press the AF-On, it gets focus on her face. I then press the shutter button, and and release AF-On and move the camera back 3 feet, it will not re-focus even though the green light is blinking and it still has the yellow box on her face. Like I said, am I missing something? Try this on your camera also.


I have window light, overhead incandescent light, f/1.8, iso 1600, shutter at 1/60. It’s bright enough.

I’m using the FTZ, NIKKOR 35mm Af-s Dx lens, wide area af, focus mode is C. It makes no difference w what lens I use either, same results.


Do I need Z lenses for this to work or am not setting/doing something correct?

Link to comment
Share on other sites

If I remember correctly, the camera was set to continuous AF with auto area on and eye/face focus enabled.

I didn't prefocus, just pressed the shutter to trigger the self timer, sat down and waited.

Out of probably 15 attempts, 12 were focused accurately - it did find my watch a couple of times.

Link to comment
Share on other sites

Well, I tried your settings, reset all autofocus settings, reset all custom controls, reset the entire camera, no change.


After another 100 shots, one hour, got 3 that worked. I could not recreate it literally right after I got the 3 with no changes to settings. To even see if it was only the Z7, I tried it with my D500. Interestingly enough, somewhat same results… did get a few better hits though. I might just give up on this endeavor, and continue using tether shooting or snapbridge.


Mr. Davies, thank you for your time.


If there is anyone else who wants to make any suggestions, please do so.

Link to comment
Share on other sites

I have window light, overhead incandescent light, f/1.8,

Focusing can be tricky with distance to subject because you are shooting wide-open with very shallow depth of field. Just to make sure it's not your hardware problem, try f/4 or even f/8 to see if you are in focus. If this works, then work from there. Good luck.

Link to comment
Share on other sites

Try this:

  • Focus Mode - AF-S
  • AF area mode - Eye detect
  • Beep Option - On (so you can hear confirmation of focus)

In Photo Shooting Menu select Interval Timer Shooting

  • Choose start time - now
  • Intervals x shots//interval - select at least 3 shots to allow you to get into position, for example 7x1.
  • Silent photography - off
  • Focus before each shot - on (most important)


Good luck

Link to comment
Share on other sites

I called Nikon support about this issue, and they wanted me to send them some .jpgs of the testing we were doing while we were on the phone. Then they sent me a bad link, and was unable to send the images requested. I then sent the images directly to them via email, but I don't think they were delivered. A catch all email address. Let's see. I will keep you all posted.


But, I did have some success tonight. I tried what Mr. Niemi suggested. Though I could not find the "Focus before each shot - on" option, I was able to do 3 rounds of interval shots, with the suggested settings, and all came out with successful images. I could hear the lens refocusing between shots, as I moved towards and away from the camera. It was an overhead light bulb, iso 1000, f/4 and shutter speed 160. It worked... I then tried the self timer again, thinking I had lady luck on my side, NOPE!! Blurry as usual. So, I now know that I can do some self portraits via interval shots, and those will work. Thank you all that made suggestions, I do appreciate your time.


*If Nikon responds, I will keep you posted.

Edited by adolfo.cruz
Link to comment
Share on other sites

Just a quick update:

Nikon emailed me this morning, and stated that they would like me to do another round of testing with better light, and a flash. I tested it with all the windows open in my apartment, a lower fstop and iso 200. I also attached the SB700 flash unit. None of the testing resulted in a more acceptable image. All were still blurry. I will be sending them the images after I get off work tonight, and I will update the forum on the findings.


Thanks again everyone.

Link to comment
Share on other sites

Last update:

I gave up all together.

Nikon stated that they could not figure out what was wrong with the images and I would have to send in my gear for review at a fee. I told them that I will continue using this, as is, and probably trade it in for a z7II or z9. So again, to everyone who helped, thank you.


Here is my latest portrait session of me and the first camera I ever used. My dads Vietnam War era Yashica FX-1.


Shot in interval mode!!!



Link to comment
Share on other sites

Nikon stated that they could not figure out what was wrong with the images and I would have to send in my gear for review at a fee. I told them that I will continue using this, as is, and probably trade it in for a z7II or z9.


Wrong answer, Adolfo. I would have replied, "Oh, well, I'll continue to use this as is and then trade it in on a Sony A1. That will solve the problem." <EVIL GRIN> Doesn't mean you have to switch to Sony or Canon, or... but you might as well add to their stomach acid level a little.


I am sorry we and they could not help you.


BTW if the self-timer is an important function for you, Vello makes a Timer/Remote for the Z7


LINK: Vello ShutterBoss II Timer Remote Switch for Nik RC-N2II B&H (bhphotovideo.com)


It usually goes on sale around the Holidays and will probably cost much less than Nikon's evaluation.

Link to comment
Share on other sites

bgelfand : Good play on my wording. I read it quickly and only on the second reading is when I noticed the switching part.


Everyone did, in part help, because I tried what was recommended and not only did I find a mode that works, it put my mind at ease knowing that I was not doing or using the feature incorrectly. I might look into the Vello. A nice Xmas gift!


Mr. Halliwell, yes, I do have the latest firmware installed. Unfortunately, it does not work. But like I stated, I may trade it in and do a slight or $MAJOR$ upgrade or even just continue using it as is. Not sure yet.

Edited by adolfo.cruz
  • Like 1
Link to comment
Share on other sites

Mr. Smith thank you for your input. I did check the lens as suggested and it didn’t make a difference.


So, yesterday I was feeling under the weather and stayed home. I decided that some retail therapy may help so I packed the z7 up and took it with me right to the camera shop and traded it in. I got a Z7ii. I did a test and posted it. Can’t complain. It does what it is supposed to and is a tad quicker. Now I’m not saying that was the perfect solution, but I am happy with my decision.


Thanks again, everyone.



Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...