Zorki C with Jupiter 12 lens (wide angle) - [problems]

Discussion in 'Classic Manual Cameras' started by rui_ferreira|1, May 21, 2015.

  1. Hello,
    I recently bought a Zorki C with its original collapsible lens plus a very well kept Jupiter 12 as part of the deal. The shutter cloth at speeds 50; 25 & Bulb stucks a bit, but still.
    I loaded it with a 400 ISO film and attached the L39 Jupiter 12 wide angle lens. I've only used the shutter speeds 500 and 250 which work in good condition.
    I've just picked up the results from the lab and almost all the pictures have some sort of flare from top to bottom.
    Some examples:
    [​IMG]
    [​IMG]
    [​IMG]
    I'm giving my first steps on film and have no idea why this happened.
    Was this because of the lens? Incorrect film development? Camera?
    Any ideas?
    Thanks
    00dImH-556858184.jpg
     
  2. Looks like something wrong with the shutter, the edges of whose curtains alone can make the vertical line. There is also a blob of light at top left.
     
  3. That blob top left is a ceiling light. Shutter bounce responsible for the rest?
     
  4. Yes it looks like the shutter needs a service.
    Film photography, especially with older cameras, can be very frustrating and discouraging when things don't go to plan. I'm going to suggest that you should consider making things easier for yourself at this stage by getting hold of a more usable modern camera, preferably an SLR which I find much more satisfying to use than rangefinders, with a nice bright focusing screen to help compose the picture. By eliminating camera problems you can then concentrate on getting the images you want. The Nikon FM and Pentax MX spring to mind, but there are of course many other possibilities.
    But do persist with film.
     
  5. curtain hang. needs cla
     
  6. The shutter cloth at speeds 50; 25 & Bulb stucks a bit, but still.​
    I agree with the above comments. You have stated above that the the slower speeds are sticky. When you open the bottom plate you will see two set screws and nuts that anchor your shutter spindles. Drop some petrol [gas] on these nuts and let them be absorbed by capillary action. After a few seconds try working the shutter. The sticky shutters will work smoother. You can also reach those anchor points on the top and bottom of spindles [on both sides of the frame] from the lens mount opening and drop some petrol [or Naphta]. Then blow clean with a blower. Everything in the shutter should work smoothly after this. You may add a drop of lubricant watch oil to the same spots.
    In addition check also the channels through which the shutter lead metal-laths run. if they are dirty then that could retard the curtains. All the best. sp.
     
  7. Thanks for the insights.
    The blob of light on top left is a lamp hanging on the ceiling :)
    I will try to find someone to have a look on the shutter...
    I will get back here with the outcome.
    Thank you all!
    00dIrR-556865484.jpg
     

Share This Page