Zenzanon EII 75mm f/2,8

Discussion in 'Medium Format' started by alessandro_fantini, Sep 19, 2009.

  1. Hi all, I've got an ETRS body with EII 75mm f/2,8 and MC 150mm f/3,5 lenses. With 75mm lens, shutter only work at 1/500. In the past, two years ago when I bought bronica, sometimes it works fine but now not.
    With 150mm lens it's all ok, I can use also other times than 1/500.
    Could be a problem with the shutter on 75mm's? Could be a problem with battery too low for EII lens and not with oldest MC 150mm ?
    I'm thinking to buy an MC 50mm f/2,8, but I'm afraid that it might not work well.
    What do you think about?
    Thanks all.
    bye
     
  2. I've had a similar problem with this lens. You can try cleaning the electrical contacts between the lens and body - this did not work with mine however, and I eventually bought a new lens. Only to try the "faulty" one again some time later, and it worked fine.
     
  3. And what was the "faulty"?
     
  4. Not sure what you mean exactly Alessandro but I never did find the actual fault. The lenses were both the same 75mm f2.8 EII. As stated the problem can be caused by poor or dirty elerctrical contacts between the body and lens. My camera worked fine with another lens (150mm) suggesting that the problem was in the lens rather than the body. Hope this helps.
     
  5. Thank you John and sorry, I understood that you found the problem.
    My english is not so good yet.
    Alessandro.
     
  6. I found the cause of the problem. I will explain in the afternoon (sorry I'm not so able with English!)
     
  7. Initially I thought that it was an electric problem, but now I'm sure that it's a mechanical problem.
    When I manually load the shutter on the lens detached from the machine, I need to turn the pins until they reach the end of the way, for having completely charged shutter. But when the lens is mounted on the camera, the camera's arms doesn't move the pins until their end-way, so the shutter is not completely armed although it and diaphram are fully opened.
    So when I click the shutter button, the shutter closes and remains closed, instead of having the sequence open-close-open(for the exposure time)-close(at the end of esposure time).
    Therefore the film remains not exposed.
    With other lenses there aren't any problems, so I think that the problem is a gap on shutter of 75mm lens.
    Do you know if it's possible regulate the moviment of the pins in some way?
     

Share This Page