Zenza Bronica ETRSi 135w Film Back winding issues

Discussion in 'Medium Format' started by conmai, Sep 10, 2019.

  1. Hi all,

    I'm having an issue with my 135w back, each time I run a test film through the manual winding process on the camera crank stops advancing the film after frame 16, the film rewind works fine at this point and I can safely rewind the film. I've only tried the one film and one body. I believe I'm loading the film correctly and everything works fine until frame 16, not sure of anayone has seen simialr issues with this bavck or the 135n one or may understand where I could start to troubleshoot?

    Kind regards
     
  2. I don't have a Bronica but I understand that the 135w back makes frames that are 24x55mm rather than the standard 24x36mm. So a 24-exposure roll would only yield 16 of the longer frames.
     
  3. Hi Jim,

    Thanks for the reply and this now makes perfect sense, I have also double checked a test film again, this time I checked the film and 16 frames is the end film of the cannister and cannot physically pull any more film out of it

    Many thanks for putting me right on this.
     
  4. Hi, I am interested in buying the 135w film back but do not have clear how to compose the image as in the viewfinder I will still be seen the full square image. I could use my imagination and compose it by what I think would be but prefer a more precise way to do it. I have not been able to find the
    Bronica microprism/split-image for film back ETRS 135 that could solve the problem. Any hints/ideas ?
    Thanks
     
  5. You could cut a viewfinder mask out of construction paper.
    I made one for 645 on Bronica S2a 6X6 body.
    Not an elegant solution but it works.
     

Share This Page