Yashica Mat 124G Flash sync problem

Discussion in 'Medium Format' started by kngharv, Jan 26, 2006.

  1. Dear all:

    I got a Yashica Mat 124G in a very good condition for about three weeks.

    I just discover that my flash sync is not working... after I bought a
    sync-PC cable.

    Yes, I've put Flash Sync to "X." The sad part is, it does fire the
    flash occationally. On average, it fires about once or twice per roll
    of 120.

    Visual inspection on PC shoe yield nothing. It looks very clean. No
    corrosion, no gunk fill the socket.

    Is there any trick I can employ to "fix" this sync issue? Or I just
    have to bite the bullet and send the camera to get it fixed (and CLAed
    at the same time)?


    ps. I used the same flash / sync cable on my Nikon FM2 and it worked
    perfectly. I am sure the problem lies upon the Yashica 124G, not the
    flash, not the cable.
  2. I had a similar issue on my old Mamiya C330s. I found the issue was that the connections weren't very good. I pinched the connectors on the sync cable to hold the connection a little tighter.
  3. If the pc socket is worn, the center pin on the cable may not consistently make good connection. Use the tip o a knife to bend the pin so it is slightly off-center, and then try it again.
  4. Dear All:

    It turned out the problem is a lot more severe. It is not just a matter of dirty socket. I had to send in to fix the circuitry.

    5 weeks and US$ 145 later, this camera is as good as new. And yes, since the camera is in the shop anyway, I went all out and got everything revamped :p

    I bought this at KEH. This kind of problem is very difficult to detect. It is one of those things that if I knew the flash synch circuitry was broken, I would not of paid that much for this camera.
  5. Dear all:

    By searching over the net, I was told Yashica MAT 124G had problem with Flash sync ever since it came out of market :D

    In my case, though, I finally pin down the problem.

    The problem was not on my Yashica at all. It was the PC-cord between the cold shoe and the flash socket. i

    The reason why I didn't think it was the PC-cord's problem is because the same cord worked flawlessly on my Nikon FM2.

    I took a leap of faith by... buying another PC-cord. I paid a lot more for this new cord and the cord seems to be better constructed.

    The new cord workes if I stuck in the PC socket REALLY REALLY TIGHT. I am not complaining, because I never take this PC cord off anymore :D

    As for why one cord works perfectly on my Nikon FM2 and doesn't on Yashica... and another cord works on my Yashica, is absolutely beyond me. If you guys knows why, please enlighten me.

    I bought the first cord in Taiwan... The country of origin is Japan.
    I bought the second cord in Ritz Camera, USA. The country of origin is China. And I paid quite a bit more for the 2nd cord for what appeared to be exactly the same thing.

Share This Page