weird little issue with my SX-70 sonar

Discussion in 'Extreme, Retro, Instant and More' started by 10986431, Feb 18, 2020.

Tags:
  1. Hi all hope you can help me diagnose the issue and maybe even what it would take to fix it.

    Basically I have a lovely SX-70 sonar polaroid and weirdly when I put new film in it didn't eject the darkslide or make any noise at all. Then I took it out and put it back in whilst the camera wasn't fully extended and iit worked fine. It seems intermittently that when the camera is fully folded out and snapped into place that there seems to be some kind of power shorting. Any idea what this might be at all? Sometimes it works fine as well, weird huh. Its a beautiful magical camera and love using it so any help on this highly appreciated.


    Best,


    Scott
     
  2. This is a folding SX-70 sonar model correct? Such as the SX-70 Sonar OneStep.

    Sounds like the interlock switch isn't making contact when the camera is fully open. The purpose of this switch is to prevent the camera from operating when folded.

    From your description it sounds like the camera does operate, but only when partially erect and not latched. It is not ideal to operate the camera in this condition. Do not attempt to fold the camera if any resistance is encountered as you could break the mechanism that allows the mirror to flip up and down if it has not cycled fully.

    Here's some instructions to fixing the interlock switch:
    SX70 camera S6 switch repair

    You will need to remove the bottom cover of the camera which involves removing the leather covering to access the four screws that retain the bottom body panel.
     
    10986431 likes this.
  3. wow thanks so much! Yes it is the folding one and yes that does seem exactly like the issue. Before attempting this myself can you suggest somewhere I might be able to do this that wouldn’t cost the earth. I love this camera and really want to get this back in service. seems like the steps might be a little tricky for my skill set but could try it if there’s no other option.
    Appreciate your help so much!
     
  4. I'm afraid I don't know who would be the best person to send this off to as I service all my own cameras. Perhaps ask on the r/polaroid sub-reddit which appears to be fairly active, as the folks there may be more knowledgeable than myself in this manner.

    There was a gentleman with the handle Fastcat on the SX-70 flickr page, but I don't know if he is active any more.
     
  5. Check with Brooklyn Film Camera. I bought a refurbished SX-70 Sonar from them in the fall, and it was in great shape. They do good work.

    Services — Brooklyn Film Camera
     
  6. OK this might be helpful for someone as this is resolved after speaking with a polaroid expert over at flickr as mentioned by Hunter_compton earlier in this thread. The person was indeed Fastcat and is still active and awesome.

    OK so Fastcat mentioned that its probably not been used in years and befoire I replace the interlock switch get the motor going properly with the item fully locked in place by opening and shutting the camera 50-60 times. I did 30 and tried it and the same problem occurred, I nearly gave up but continumed to do another 30 or so and it worked!!! I ran a few tests and the camera is running Awesome. The camera probably sat fully extended and open for years and years and years and needed to have its old joints flexing again.

    Word of note if you try this, please make sure it feels like its closing OK, do not force it as it could be the mirror out of place and that could get damaged badly so make sure it feels like its opening and closing correctly.
     

Share This Page