Wein Ultra-slave not firing Novatron 500 VR lights

Discussion in 'Lighting Equipment' started by meisterman, Mar 10, 2006.

  1. OK I picked up a Wein ultra slave and SSR -jr transmitter but can't
    get it to fire my Novatrons. The first one I recieved would not work
    so I sent it to Wein and just recieved the replacement today and it
    won't work either.
    Here is the dilemma... When plugged into the household plug on the
    500 VR box it will not trigger the lights. It will trigger my Metz
    45 CTL flash with the female end of the Metz sync cord plugged into
    the Ultra Slave. (The transmitter seems to be good and fires every
    time.)
    But I then plug a female end of a household sync cord to the Ultra
    Slave and it won't fire the novatrons.
    I then tried the household sync cord straight from the camera to the
    Novatrons and they fire every time.
    Its been very puzzling to me. I have tried putting the Ultra Slave
    in the Novatron both ways (turning it 180 degrees)and nothing.
    has anyone had this problem or know a solution ?
    I bought it to use for my Canon 20D and it has frustrated the heck
    out of me.
    Thanks for any insight you may have.
    Klaus
     
  2. Don't know the answer. I've gotten two bad Wein slaves in a row myself -- not this model, though. Never again, either.
     

Share This Page