Unable to detect camera / Media C-5060 Zoom

Discussion in 'Olympus' started by sol_k, Sep 10, 2007.

  1. I had ( RIP )an Olympus c-5050 Zoom camera which I used with my emac Computers (
    MAC OS 10.2 & 10.3 with all updates installed). All was well and working . I was
    able to directly open the media cards ( Both XD and FLASH CARD ) on my desktop
    as an external drive , transfer the files from the media to another folder on
    the desktop, and later process them using my photo software of choice.


    Then the c-5050 suddenly stopped working with a lens problem not retracting , as
    if though the lens was hit but it was not.

    So I sent in the camera to Olympus and they quoted me $200 to fix it , which of
    course is not an intelligent choice since once its done, after 30 days one is up
    sh*ts creek again.


    Now I figured I buy a used one and it just always was higher priced than it
    would cost to repair so as an alternative I bought a c-5060 zoom so that I don't
    have to learn everything again, thinking it basically has the same functionality.

    So finally it arrived last week.

    NO battery, no charger!

    So a week later I got battery and charger ( not original Olympus ) and plugged
    the battery in and it takes pictures! ( I guess I am pretty lucky that it does) .

    Comes down to downloading the images from the camera to my MAC. When I power up
    the camera to download , the camera ( or rather the media ) does not show up on
    the desktop and the camera's monitor says ( ONE MOMENT ) and it just sits there.

    I tried using the CAmedia MAster software ( Version 4.1 WHich I am not sure if
    it is the correct version as the seller indicated that the camera comes with
    batter and charger and everything else and it did not ) and when attempt is made
    to connect and download , it comes back with a message ( UNABLE TO DETECT AN
    OLYMPUS DIGITAL CAMERA)

    I tried to check to see if there is any firmware update for C-5060 Zoom on
    Olympus site and there is none for MAC , one for PC and the update list does not
    include this problem.

    I tried iphoto ( MAC SOFTWARE ) and iphoto is able to download the images but it
    will be a great pain to go through iphoto.

    So does anyone know what is wrong, and how I can get this media to show on my
    desktop as a regular drive?

    Thank you in advance for any hints or help.

    Sol.
     
  2. Ok, I am an idiot. The USB port was set to PRINTER.
    Solved.
     

Share This Page