SQ-Ai & Speed Grip S issue

Discussion in 'Medium Format' started by guy_gervais, Mar 6, 2013.

  1. Hello everyone,
    I'm having an issue with my SQ-Ai & the Speed Grip.
    I am able to advance the film but it refuses to trip the shutter.
    Also I noticed that as soon as I install the grip on the camera, the battery check LED lights up.
    The camera works just fine without the grip...
    Anyone experience this before?
    Thanks for the help,
    G
     
  2. Couple of possibilities on the shutter trip:
    - mechanical adjustment: there's a linkage inside you can see by removing two plates, one is obvious and the other is accessed by peeling up the corners of the rubber mat under the camera and removing the screws there. I don't know how to do the adjustments, just that they are there. Should be fairly simple to figure out though.
    - shutter release is locked - insure the button on the base is pushed away from the red dot. Mine had the opposite problem: it would release when "locked"
    The electrical issue sounds like one of the two wires inside the grip might be shorted to the housing. If you need photos of anything let me know.
     
  3. Thanks for the tip.
    Wires seem fine. Shutter release is not locked.
    I have no patience for thesethings. Off to the Recycling bin!
    Regards,
    G
     
  4. A couple of things before the grip hits the bin. I use one on an SQ-B and have had the same(intermittent) problem.
    Dumbass issue when I first got it? The release lock on the grip was engaged.
    I've found I can't just attach the winder and shoot. Often fiddling with positioning the winder is necessary to get it to fire. Sometimes takes a couple of tries.
    No clue about the battery light. The SQ-B lacks a few of the SQ-A(i)s electrical circuits(e.g., connection to the back and VF).
    It really does improve the handling of these boxes and is worth the time to get it working.
     
  5. david_henderson

    david_henderson www.photography001.com

    Clearly you have a problem with this device. However they are not congenitally or even often wrong. I've seen just about every Bronica thread on Photo.net in the last fifteen years, and the number of problems with or caused by Speedgrip failure is certainly well under 10. It may well be cheaper to buy another than get a broken one fixed.
    There really isn't a lot to these things- something to grip and turn the winding knob, and something to press in the shutter release at the bottom right front of the camera, viewed from behind. In the first case its replacing a plastic crank handle; in the second its replacing your finger.
    It might be possible that the Speedgrip isn't turning the winding knob and therefore advancing the film quite far enough to permit shutter release. You can try this simply enough by attaching the Speedgip, winding on with it, and if the camera won't fire, take the speedgrip off carefully and without moving the winding knob. Now try and fire the shutter using the button on the front. If it fires, and you do this a few times and it always fires, then the Speedgrip's linkage to winding mechanism is faulty.
    Alternatively, when you have the Speedgrip fitted, and you press the shutter release on its handle, does it move the shutter button on the front of the camera? Bear in mind that both the speedgrip lock and the locking collar on the shutter button on front of the camera must be set to "unlock". If both are unlocked and the operation of the release on the Speedgrip doesn't move the shutter button on the camera- or doesn't move it enough to fire the shutter- then thats a linkage issue that I believe can be resolved by adjustment. Though to me that would mean an adjustment caried out by someone else.
     
  6. Thank you all for your replies.
    Speed grip is history! Replacing it with a motor drive.
    G
     
  7. They're not that hard to work on, either. I'm not sure why mine worked the way it did, looks to me like sloppy manufacturing tolerances. I cured my non-locking "lock" button by adding a shim to take up some slop in the linkage. Now my lock button locks the grip and all is well with the world!
     
  8. I had the same issue, and noticed the lever (I guess that's what is is?) that pushes in to depress the shutter release was, when attached, already pushing the shutter release in a little (this is on an SQ-Ai body). My body also fires fine without the grip but did nothing with it attached.
    I removed the speed grip, cocked the shutter while pushing in the shutter release a little, and there we go - the shutter won't fire. If I then released the pressure on the shutter release, voila - everything works as expected.
    On my speed grip, the tip of said lever on the grip has a plastic covering around it, so I popped that off and tried again. Still nothing, so gently with a pair of pliers I bent that tip outward ever so slightly, and now all works fine. No costly repairs or hunting down a new grip.
    Looking at pictures online of the various S and SQ bodies, it seems the shutter release button is not universal between them. I have never found a manual for my speed grip S and as such am not sure if there are variations on the speed grip depending on which body you are using, but it's worth trying what I did if you pick one up and have the same issues mentioned above.
     

Share This Page

1111