Sony XQD USB card reader stopped working

Discussion in 'Digital Darkroom' started by rconey, Oct 20, 2021.

  1. Hello all,

    Glad the site certificate got updated. I was concerned. Anyway, I have used a Sony XQD USB adapter since 2018 when I got my nikon D850. Never a problem using it to transfer images to my computer. When I got back from atrip in early September, I found that the computer does not even acknowledge my plugging it into the USB port. Nothing. Looking into the File Manager, the device does not show up. Being a pack rat, I bought two back in 2018 so got the new, unused one. Same behavior, not acknowledged at all.

    Anyone else seen this? Maybe a Windows update altered XQD card reader recognition? I can buy a new card reader, but it seems silly. Thx.
  2. No troubles with my Windows system here so I doubt there was an update problem. Do you know the port works? Can you try a different computer? Did you accidently put a CFexpress card in? Mine doesn't show up if I do that.
  3. Try using a different USB cable between the Card reader and the computer. If you need to buy a new one, et the highest quality USB cable you can find. When I have had similar issues with external hard drives, the problem has been the cable and not the drive.
  4. Thanks all. The USP ports work with other items. I tried the USB cable that comes with the device, instead of directly plugging it into the computer USB port. As I said, I even tried the new, unused device I had sitting in a drawer. Neither is recognized by the computer. I have had to get the short Nikon USB cable and download directly from the camera- a pain but it works. Hmmm
  5. Well that's interesting. It is the XQD card that is the problem. It is a 128GB SanDisk Extreme Pro that I have used for a year or 3. It works fine in the camera, and with the camera USB cable images download without problem. In the adapter however, the computer does not pick up the connection. Hmm. Who'd a thunk. Guess its heading for the trash.
  6. There is a Windows tool called "Hardware Troubleshooter" which may help. This article refers to SD cards, which can have a similar problem in Windows 10. Windows may not recognize the file system of the XQD card, in shich case it wouldn't show up at all.

    Quickly Fix SD Card Reader Not Working on Windows 10

    IMO, this may be the 1002nd reason to switch to Mac. Macs have problems, but you're more likely to find a solution from other users.
  7. Before you throw out the card, try this. Attach the empty card reader to your computer. It should recognize it as a drive with a letter like D or E. Then enter the XQD card. The drive letter should change if the computer recognizes the card. If the computer does not recognize the card, press on the card to unload it. Then load it again. And see if the computer recognizes the card.

    With my Sony XQD card reader attached to a win 10 laptop, I attach the card reader first to make sure the computer recognizes it. When it does, it gives me the drive letter. Then I put in the XQD card. Sometimes I get instant recognition. Other times I have to press on the card to unload and reload it to get the computer to recognize it.

    From your description I do not think the problem is the card. It might be the card reader, cable or both. If you have a second USB port, try that. It could be the port too.

    If you have a friend who has the same type of computer, try to see if the card reader works on his computer.
  8. As above, it could be that Windows is conflicting the drive letter assigned to your card with something else connected to the computer. Unplug everything else, try again.

    You can change the letters Windows assigns to drives, but I can't remember how and have no Windows computer to check on, sorry.

    Could also be formatting, best bet is to get a friendly Linux user to do a total rebuild of the card, zero it out and rebuild from the partition table up.

    Or it could be dead.

    Had all of the above happen to me with USB keys, the drive letter conflict is a regular annoyance that should have been fixed 20 years ago, screwing up the partition table so badly that Windows can no longer see the card/drive is a total showstopper.
    Last edited: Oct 22, 2021
  9. Since the camera can write to the card and when you use a USB cable to attach the camera to your computer you can download the images from the card to the computer, I doubt the problem is the card. I suspect it may be the the card reader.

    Three places to check.

    1) The USB port, both on the reader and computer. Try plugging the reader into a different USB port and definitely a USB port on the computer itself, not a hub or an extension cord.

    2) The contacts between the adapter and the card, Are the contacts clean?

    3) It could be the electronics in the adapter itself.

    Without the adapter plugged in, right click on START and select Device Manager. Expand Disk drives. Now plug in the adapter without a card in it. Do the list of disk drives in Device Manager change? If so, the new entry is your adapter. Remove the adapter, insert the card and plug the adapter back in. Do you see the adapter with card in list of drives in Device Manager? If so, on to the next step. Right click on START and select Disk Management. The Disk Management window is divided in an upper and lower half. If you do not see the card in the upper half, scroll down in the lower half and look for it. If you find it in the lower half, right click on it and assign a letter - pick one the system will not normally assign - say M or N. All should be good.

    If you still do not see the card, first make sure the card is inserted in the card reader correctly. Last time I had this happen, I had inserted the card backward (I am using an SD card and reader). Of course there was not card; there are no contacts on that side of the card. If the card is inserted correctly, then in Device Manager, right click on the adapter and chose Uninstall, disconnect the adapter, and after a minute plug it back in. Windows should reinstall the device and drivers.

    If you never saw the device in Device Manager, it is probably broken. Keep the card and get a new adapter.

    I hope this helps.
  10. That's what I was trying to say above, but I can never remember how to do it without a Windows computer in front of me!

    Seriously, Windows disk management, with only some 20-odd letters that can be assigned (some are reserved) was barely acceptable in the DOS days, now, with multiple partitions, external hard drives, USB keys, memory cards etc, it's just a liability. Yesterday, I add to add a new network share to a computer at work, I think my remaining choices were K,L and Z...
  11. Try de-installing and re-installing the driver for the USB ports.

    I have a similar intermittent issue with a Renesas-chipped add in USB 3 card. Sometimes it just refuses to acknowledge an external USB-to-SATA HDD dock. The only fix I've found to date is to remove the USB 3.0 ports in Device Manager, then click on "Look for Hardware Changes" and let the drivers automatically re-install.

    BTW, I have Automatic Updates turned off, so why that particular driver should apparently become randomly corrupted, I have no idea.
    X, Y and Z are the default assignments for network shares, IIRC. Never seen a computer with drive letters down at R, S, T, U or V though. C'mon, 20 plus partitions or drives is a bit excessive, you must admit. And you can hide system-reserved partitions by deleting their drive letter.
    Last edited: Oct 23, 2021
  12. Ahhh, I moved too quickly. The card in question is at the bottom of a garbage bag. It would have been interesting to sort through where the problem was, but my other xqd cards are working fine. There are 3 usb ports on the front of my computer-only that old card did not register, in any of them. I had reformatted it in the camera a few times, to no avail. Thanks for all the good suggestions.
  13. Works computer (so largely outside of my control), connected to a bunch of CNC machines. The CNC software can only cope with mapped drive letters, not network locations accessed via \\server\directory\file (because it dates from the DOS era too). Each CNC has 3 partitions mapped as shared drives, combine that with a few partitions on the PC, a few other network shares, some USB keys with hard assigned letters because Windows can't see both of them at the same time, a share for Virtualbox and it fills up pretty fast.
  14. I never use a card reader. I always download direct from the camera. Solves that problem. I never quite see the point of having a card reader. I have large capacity cards in the camera and just connect via USB-C.
    Last edited: Nov 19, 2021
  15. No doubt it depends on the camera. New Nikons are supposed to be better, but camera transfer on the first Z series are pretty slow. Using a card reader is over 300 MB/s for me. Camera transfer is more like 40. Doesn't matter for a few files but tedious if you have a bunch.
  16. I agree that transfer direct from camera is pretty slow. The card reader zips thru pretty quickly. I haven't had any more problem since getting rid of that faulty XQD card.
  17. A card reader is at least 3x as fast as downloading from the camera. There's a limit to my patience when there's work to be done. Furthermore, the camera's USB connector is a weak point and very expensive to repair, whereas readers are inexpensive and readily available.
  18. I just connect and leave it. 1000 images takes a few minutes, but I suppose for some that time could be spent doing something much more valuable. What about pins/sockets for CF cards or SD card contacts, I suppose they are impervious to wear. Ah yes and of course card readers don't stop working either. To each their own. My point is that there is no requirement to actually use a card reader and I have never once missed not using it. There's always something else you can be doing when importing, such as browsing Photonet.

Share This Page