Sigma lens doesn’t stop down with adapter

Discussion in 'Nikon' started by Fiodor, Aug 14, 2021.

  1. I just saw that when I turn the aperture ring, I don’t see any diaphragm closing in the lens.

    The adapter I have can work with Nikon G lenses (without aperture ring) by changing the position of a ring. But this Sigma lens can’t stop down even if I change the position of that ring (it is not a G lens, it is something different).

    So, I guess it is impossible to stop it down…
  2. Have a look at the Fuji manual to see if there is a setting to allow Select Aperture by Ring...or some such.

    Such an option exists on Nikon cameras for older non G lenses.
    Fiodor likes this.
  3. The adapted lens will be 'dumb' as far as the camera is concerned, so it's entirely down to the adapter and the lens.

    Any chance that it's a 'fly by wire' lens and the aperture control is electronic? In which case, I suspect that you're out of luck...
    Fiodor likes this.
  4. If manually rotating the A ring has no effect, then the adapter and/or body are keeping if that way ie holding if fully open.

    No way is that lens an E lens! AF-D ensures that one..:D
    Fiodor likes this.
  5. Thank you!

    I tried the lens with a Nikon D80 and first, I didn’t get different exposures when I changed the aperture (I have to set the aperture ring at 22 and then dial the aperture on the D80). The EXIF was recorded with different F number, but the exposure was the same.

    But then, after some photos and fiddling around with the manual/auto focus switch, the problem was solved (now the aperture changes the exposure).

    So, after that, I removed the lens and I could see the diaphragm at the aperture set on the aperture ring. I discovered the lever, which I didn’t know before, and if I push the lever, the diaphragm opens.

    So… Should I try the lens again with the adapter and the Fuji camera? Is the adapter doing something wrong to the lens?
  6. Does the adapter have a lever that moves the lever you've just found on the lens?

    ...and equally does the adapter have a lever on the body side?

    ... and then is there a lever inside the Fuji throat?

    or is there a motor powered lever in the adapter?
    Fiodor likes this.
  7. Sounds like the Sigma lens initially had a stuck aperture, or the lever in the adapter wasn't moving the lever in the lens.

    Either way; it must have been a purely mechanical issue, since there's no electronic control of the lens aperture, and no electrical passthrough connection in the adapter.

    Could the aperture blades in the lens have stuck with oil? That's a fairly common problem.

    FWIW, I have a similar Sony E to Nikon G adapter. The aperture is controlled by a rotating ring on the adapter, and a non-G lens has to be set to minimum aperture, or to the desired aperture. It's easy to knock the adapter ring to the wide open position or to forget to stop the lens right down. Either of these result in a wider than expected aperture.
    Last edited: Aug 15, 2021
    Fiodor likes this.
  8. Previously, I tried this Sigma lens twice with the adapter and the XT3, and I wasn’t able to stop down.

    But now I can. And I realized that the lens must be inserted only when the adapter ring is on one side (and not on the other side). Both times I tried previously, I imagine I must have inserted it with the ring on the wrong position. I really don’t know if that is possible. But if it is, I did in a way that pushed the lever in a way that block or cause trouble to the lever.

    I am just guessing…

    But the important thing is that the problem was solved.

    Thank you!
    mike_halliwell likes this.
  9. My PhotodioX Canon to Sony adapter wasn't working with my Tamron 70-300 and Canon 85/1.8. Was working with Canon 24-70/2.8.
    Its hit and miss situation.
  10. Have you called Tamron Support and asked if there is a firmware update for your lens? There may not be depending upon the age of the lens, but I have always found Tamron support very helpful.
  11. I sold all Canon lenses anyway, and its not Tamron problems, its adapter problems.

Share This Page