Sigma 17-70 "Contemporary": compatibility problems with Shake Reduction

Discussion in 'Pentax' started by spronju_lator, Jan 9, 2015.

  1. There appears to be a problem with the Pentax version of this lens. Under 31mm it is communicating the wrong SR Focal Length by a very large margin. This introduces blurring when SR is on. Please check the following thread about it on PentaxForums.com. It has been verified by a number of users with the lens on different Pentax models.
    http://www.pentaxforums.com/forums/...y-compatibility-problems-shake-reduction.html
    If you own the lens, please check it out. Also, I would suggest that you contact Sigma to inform them of this problem so that that can issue a firmware fix to send the right SR Focal Length.
     
  2. Downloaded the latest version of the PhotoMe...... This software hadn't this particular info at all to give from pictures taken at 17mm with either of my cameras....K-5 and K-3 PE...
    So as for now I just did a very very simple test.... using my K-3 and the lens at 17mm with shutter at 1/15...
    With simple I mean that I only used the third step with the on/off lever on the camera.
    Closing in and comparing pictures gave actually this result...SR on gave less "blurry" picture....
    But as I wrote this was a very very simple test... I do understand that I have to take real pictues for comparing....
    I do wonder though if the firmware in camera has to do anything with this problem...
    My K-3 PE have firmware 1,11...........
     
  3. That's interesting.
    Other users found that in PhotoMe they were able to see SRFocalLength in the Manufacturer Notes field for the K-5, K5-ii and, I think, some other models, but it was not visible for the K-3. And, the values passed were wildly off under 31mm.
    Everyone on PentaxForums.com who did the 1/15 sec test found that sharp results were possible at 17mm without SR, but much more unlikely with SR. It's interesting that you got a different result.
     
  4. Today (saturday) I got some confirmation to my previous text.... Took some pictures to be able to compare SR on or SR off.... The camera was set to 1/50 (f8) and the lens in this case to 28mm... Viewing those two pictures at the same time on my monitor clearly showed that with the SR off the picture was blurrier.....
    So, once again.....This particular Sigma lens might actually work correctly when your K-3 has firmware 1,11........well, mine actually seems to do that.
     

Share This Page

1111