RZ67 problem

Discussion in 'Medium Format' started by troyammons, Mar 14, 2010.

  1. New battery and the lens is till stuck on the default no battery setting of 1/400 (I think)
    It does not respond to any speed setting.
    Where do I start to troubleshoot where the problem is ??
     
  2. Troy,
    How long have you had the camera?
    Do the LEDs in the viewfinder light up?
    Are you using a mirror up double cable release?
    Christoph
     
  3. Edit,
    Okay it works with the shutter button on the orange dot at 1/400, no lights at all even with the dark slide in.
    With the shutter button on white, the shutter will not trip, nothing like it is not fully cocked.
    With shutter button on white and the dark slide in the red light stay on all the time.
    With the shutter button on white the orange light is on all the time no matter what.
    With the shutter button on red the orange light is on all the time.
    Kindof seems like the shutter button might be stuck or a short ??
     
  4. The orange setting is the manual override at 1/400th of a second. So that one works as expected, as it doesn't need any battery power.
    It looks like the battery is low (sometimes even happens with new ones), or one of the contacts of the camera is not clean.
    First, wipe all the gold contacts clean, lens, finder, back to make sure that the power is flowing the right way through the camera. If there is still a problem, try another new battery.
    Does the camera beep?
    Christoph
     
  5. No beep.
     
  6. The beep would show that the battery is on its last leg.
    Christoph
     
  7. I assume that when the orange light is on, (goes off when I push the release button which I think is just opposite, IE it should go on when I push the button) that means the camera is not cocked.
    At least that is what the manual says.
    So its like the camera switch under the shutter release button is stuck or shorted.
    Do you have a link to a diagram for disassebly ??
     
  8. I don't have the repair manual. I'd have it CLA'd. Mine drained battery power within a few days a year ago and the CLA done by a shop in Toronto brought it back to normal.
    Christoph
     
  9. Hi Troy, too tired to think tonight but if I have your email address I'll send the repair manual .pdf tomorrow.
    Someone was recently kind enough to send it to me in return for passing it on to anyone who asked and I'm glad of this first opportunity.
    I'll think about the fault too - tomorrow.
     
  10. Troy are you sure the lens is cocked. You need to remove it and cock it manualy move the pins to manualy cock it. It possibly the problem. This can happen. Otherwise make sure the darkside plate is removed and the orange switch is set correctly. Put the mode to M for multiple exsposure with magazine without film in it. It will not shoot test shot without film if you do not put it in M. Regards Carl
     
  11. Carl may have something here...make sure you have film loaded. I thought my RZ67 Pro II was acting nuts until I put film in it and then everything worked as normal.
    David - can you please e-mail me a copy of the repair manual at William.Markey@yahoo.com? I would appreciate it!
     
  12. Good point. Its been a long time since I used this camera. It does have another problem of intermittent shutter release.
    Probably just needs a good CLA.
     
  13. So the update is,,,,
    I usually keep a dead roll of film around for testing etc.
    Yesterday before I posted, I tried a roll of film and no go.
    I have been taking the battery out thinking there might be a battery drain.
    Today I was fiddling around with the body with no lens on it no back either and the shutter tripped.
    I put if back together and loaded a roll of dead film.
    It worked fine, and the shutter would trip on M or normal but intermittently, IE I might push the button once and it would fire or it might take several pushes.
    Something weird happened though. At the end of the roll, I pushed the shutter button, Nothing, so I set the camera down and about 30-60 seconds later the shutter tripped. Dont know if this is normal or not.
    I then checked to make sure no lights were on in the viewfinder and set the camera down.
    2 hours later the battery is dead, so I am thinking the electromagnetic switch behind the shutter button might be sticking and killing the battery. Either that or it could have a bad solder joint and or a short.
    Also how do you remove the bottom cover plate. I have all the screws out but it seems like there are a few more hidden screws since it wont budge and I don't want to force it. The manual is not real clear on how the bottom is removed. At least I could not find any diagrams. Do have a few blank pages in the PDF repair manual though.
    Any comments appreciated.
     
  14. Hi David,
    I don't think we have talked yet, I would appreciate a copy of the RZ manual you have. I am rhale@hale.co.nz.
    Hi Troy,
    First, your RZ should fire the shutter system without a back on, with a lens on if the lever is in the multi postion. The lens shutter spring should be cocked before the lens is mounted.
    To clean the button shaped contacts I have found an artist’s eraser is best, just don't let the dross get in to anything. The pin shaped ones you should use contact cleaner on a cotton bud, don't spray contact clean on the pins it will go where it will not do good. While cleaning check that battery compartment is clean. There's point you do have the battery in the right way round ?
    Now be aware that the shutter up cable on connector on the lens needs to be all the way in when not in use. So that the red band is either out sight or very nearly so also the boss should lie in the middle of it's hole not tipped over. If the connector is not fully home, you will need to mount a release cable to bring it out. You can use any standard cable in this connector, once you have the connector fully out you should be able unscrew the cable to let the connector return home. This may be the source you problems, as weird things happen if the connect is not seated correctly.
    Regards Rob
     
  15. RZ manuals are avail for download on Mamiya site
    http://www.mamiya.com/customer-service-instruction-manuals-downloads-6x7.html
     
  16. Hi William,
    Sorry I didn't spot your request for the manual earlier, working crazy hours, really tired.
    Had a few people asking for this so I've uploaded it to MediaFire - anyone can download from here:
    http://www.mediafire.com/?sharekey=41b0c629a8bae47e6b21be4093fab7acd423d92f97835b639d4bfef7ef5beeff
    New to MediaFire - if this is the wrong link please let me know? Time for bed.
     
  17. Had the same problem back in 2006. I sent the camera to Mamiya America Corporation (8 westchester plaza, Elmsford, NY) for repair. According to them it was an electrical Problem, Racks Loose, Arm Loose. The cost for repair was $390.00. I'm having the same problem again so what i did was set it at the orange dot and use my flash.
     
  18. Hi everybody,
    I'm just reviving this old thread because another member recently emailed me for a copy of the RZ67 repair manual.
    The link to MediaFire (link) in my post (Mar 15, 2010) still works. The 3-part manual can be downloaded by anyone without joining or registering - just download one part at a time.
    I don't often visit the forum because macular degeneration prevents me from focussing a camera now.
    If any UK based ebayer wants to hear about a van load of pro film stuff just email me.
    Not interested in selling piecemeal, sorry.
     

Share This Page

1111