Rebel XTi Error 05?

Discussion in 'Canon EOS' started by mark_gulbrandsen|2, May 2, 2009.

  1. When I use the button to pop up my flash I get Error 05 on the LCD screen and three loud clicks from the mechanical action inside the camera. I did a Google on this problem and other Canon digital cameras have had the same problem, however unlike others that have had stuck flashes this flash does not get stuck and pops up just fine. The readout says to turn the camera off then back on again. Same thing happens. And still no flash. I also do not get the flash ready readout in the viewfinder. Then all of a sudden the flash might start working all by itself and for the remainder of the shoot it is also fine. Canon repair wants 200 bucks to repair it (flat rate) and I'm so frustrated with it that I'd almost prefer to just video it getting run over by a steam roller and post it on You-Tube. Since the lenses I have for it are also pretty mediocre I am leary of putting 200 bucks into repairing this thing but at the same time I am also leary of spending big bucks on purchasing decent glass for it. I will also add that back in the late 70's-early 80's I was a repair tech at Canon factory service in Elmhurst, Il. I mainly worked on AE-1's and A-1's at the time but back then they had 4 tiers of repair rates (A,B,C,D). In spite of my Canon background I really wish I had bought the Nikon 60D instead as Nikon seems to have a better service set up than the present day Canon does as well as better glass.
    Thanks in advance for any insight to this problem!
    Mark
     
  2. There are two versions of this problem: 1. The flash does not pop-up. 2. The flash does pop-up.
    Here’s the fix to the err05 msg when the flash does pop-up. This will work on the XTi and perhaps on similar Canon cameras:
    The pop-up flash has two legs. Look at the pivot point of the right leg (”right” when looking into the lens). Just in front of the pivot is a very small spring-load pin on the “roof” of the camera body.
    This pin is the sensor that tells the camera the state of the flash. The pin is pushed down when the pop-up flash is closed and is suppose to quickly spring up when the flash is opened. Problem is, the pin sometimes gets dirty and drags. When it is slow to spring up … you get the err05 message.
    Fix: Take a small jeweler’s screwdriver and dip the tip in isopropyl alcohol. (Don’t use any other solvent unless it’s designed for cleaning electronic parts!) Then touch the screwdriver tip to the pin. Do this several times until the pin area is nicely wet. Then push the pin up and down until it is able to spring up quickly.
    Enjoy.
     
  3. Hi
    I also have the Error 05 , but my flash does not pop up. What to do ?
    I´m a new member.
    Holger Almholt
     
  4. You were right wgk22 , it was a stuck pin and there was alot of debris around it was well. I've cleaned up that area under the flash and the pin now moves freely. Sad that Canon wold have charged me 300 bucks to do the same simpleton task! Flash is now working consistantly good. Thank You!
    Mark
     
  5. I have the same problem with my T1i, (only one week old) I will try your cleaning method. Thanks!
     
  6. I had this exact problem, Err 05, and used a q-tip that was fairly well saturated with fiber-optic grade alcohol. After 4 or 5 passes over the tip it started to pop up then finally up all they way. I gave it a couple more wipes and good as new.
     
  7. Thank you for this post and thanks to wgk22 for the advice - I was having the same problem as Mark (on my Rebel XSi) and managed to loosen the stuck pin with only my fingernail. I really appreciate the help!
     
  8. Used on my Cannon XSI worked great but the spring was on the right and the sensor pin on the left.TY verry much.
     
  9. Mark, Thank you so much for this advice. I was getting frustrated with my camera and it is only 9 months old. Mine wouldn't pop up very often and thus wouldn't let me take a picture. After reading your entry I worked and worked until it finally popped up. Just blew air on the underside of flash and it's as good as new. Must have been as simple as a piece of dust or lint in there. So, glad I looked here instead of calling Canon.
     
  10. Thanks everyone. Particularly Gerard Snow. I have been trying for nearly a year to fix this issue. I know what happened, got a little salt water on the camera during a visit to Cozumel Mexico. I have been trying to clean the spring on the right of my XSI, but thanks to Gerard, a simple swipe of alcohol to the left sprung the sensor pin and I am good to go now.
     
  11. "Ingenious" worked on the the first try. Thanx!
     
  12. I had this error code and the flash didn't pop up. It would pop up occastionally but it would stick 9 out of 10 times and there was nothing sticky ever on the camera. I read a suggestion about removing a small amount of plastic right behind the canon logo between the flash and camera. I took an exacto knife a scraped 4 or 5 times across the area and so far so good. It has only been a few days...but it has worked for all shots since. Much better than the $200 trip to canon.
     
  13. My problem was similar. My flash would open, click three times, and then give me the error. The pin was clean. The camera was behaving like it never recognized the flash being closed.
    As it turns out, the sensor to the left of the flash was pressed in and not popping back up when the flash opened. I cleaned the sensor to the left of the flash (to the left if you're looking at the camera straight on), and since then the error has gone away.
    I uploaded a YouTube video with a visual:
    http://www.youtube.com/watch?v=vPOi...ADvjVQa1PpcFNU67USckaH09vMOS20u2bAil-4GFuxjn4=
     
  14. Thank you @
    wgk22 wgk22 for your fix it on the Error Code 05 on my canon T1i rebel. My problem was it kept saying the flash wouldn't pop up but it would. It just kept making those three clicking noises. I showed my husband your solution, (I was looking at my camera wrong); and he fixed it with no problem. Thank you again!

    Diane H. California
     

Share This Page