Rebel XT problem - camera won't fire shutter

Discussion in 'Canon EOS' started by eric_ellis|1, Oct 21, 2007.

  1. Hi -

    My wife's XT may be getting a little long in the tooth, but until recently it'd
    functioned great. Now it's acting weird.

    Essentially, it refuses to fire the shutter when the button is pushed.
    Unfortunately, I don't have any remote control or cable release to test firing
    it that way.

    The camera powers up normally, meters normally, and it autofocuses without issue
    - I've tested it with multiple lenses and get the same behavior, in both
    autofocus and manual-focus modes. The behavior is the same regardless of which
    shooting mode (P, Tv, Av, M, etc). I've cleaned the electrical contact points
    between the lens and camera. I've checked to see that the mirror isn't
    mechanically stuck (it isn't). I've swapped batteries, and removed both the
    large and small batteries simultaneously to ensure that it doesn't have any
    juice to save stored settings. It's as if the second step of its two-step
    shutter button no longer functions.

    It seems to me like this is a matter for Canon Repair to take a look at, but
    before I do that, anyone have any suggestions for something further I could or
    should do to troubleshoot? I can't find an option to do a hard reboot like I
    might do on a PDA or a computer, and there doesn't appear to be a software reset.

    Any advice would be greatly appreciated! Thanks for reading!

    Eric Ellis
     
  2. I know that this seems pretty sill, but make sure that you don't have the self timer turned on by accident.
     
  3. One way to get a "reset" would be to remove both the main battery and the small "button" battery. Leave them out for about 1 hour and reinstall.
     
  4. Try to reflash the camera with firmware just incase there is a clitch there. If that does not help(to be honest it is a long shot), then I think you have tried it all.

    Good luck

    Jason
     
  5. Ellis, I sort of had this 'problem' when I first got my XT. It turns out that I simply forgot to turn off the mirror lock-up. On a self timer the shutter will fire after a few seconds. Without it one would have to press the shutter button a second time to shoot. You will notice that the viewfinder will black out when this happens. Check you custom settings. Also there is a selection in the camera's menu where you could "Clear all settings." Try that and let us know if that helps.
    Jam
     
  6. Eric,

    One more thing you can try is shooting without flash - if you have the flash up and it doesn't fire then obviously it is the flash. I hate to be pessimistic but it seems as if you may have damage on the cf board (i.e. bent pins) so open up the cf door and look inside for any bent pins. Bent pins would cause this because the camera wouldn't detect the card and threfore would not shoot. The other thing you can do is set the camera to shoot without a card (custom function) by disabling the card lock, that way, if it was bent pins or even a memory card problem you would be able to see because it will at least be able to take a picture. Also, look around in the menu, there is a software camera setting reset that you can do and you should defenitly do that just in case.
    good luck
    Mark
     
  7. Thanks very much to all that have contributed advice - I'm very, very appreciative.

    So far nothing seems to have altered the behavior described in the original post, but I haven't had a chance to try a couple of items suggested yet.

    1. Camera isn't set to the timed release ;) Checked that one because I've made that mistake before!

    2. Mirror lock up isn't at issue, because the shutter release isn't causing the mirror to move into the locked-up position. What I have checked is to see that if I use a pencil (eraser-end), I can move the mirror into the "Up" position, and it's moving freely without any apparent catching.

    3. Tried the "pull both batteries for an hour" suggestion by leaving them out overnight while I slept. No change once I reinserted them this morning.

    4. The camera was previously set to shoot without a CF card (I dunno why), but I haven't had a chance to look at the pins yet - I'll do that tonight.

    5. I haven't reflashed the camera. I didn't know that was an option, though it makes sense (what with it being a computer and all). I'll do my research and see what that takes tonight as well.

    Thanks again for all the help - I feel much better about my decision to toss my hands up and look stupid in my wife's eyes...

    Eric Ellis
     
  8. My original Rebel (which I love) just did the same thing. ALso showed "err 99" in window. Means generic lens problem, but changing lenses, battery and card did not help. Conked out just as I arrived in Istanbul for 5 day stay! Mirror would not lift thus shutter would not open. You hear soft 1st step to fire, then nothing. Local dealer and online tech could not fix. FInally sent to main repair in NJ. (Canon online will give you address) Just got answer yesterday; $195 to fix. No explaination of cause.
    Ended up buying 40D (and better lenes) to replace. May fix and give to my son, since I have original lenes.
    Bob Miller
     
  9. Hello,

    I was having similar trouble with my XT, so I did a search and it lead me here. While none of the stuff above worked, I was sitting here fooling with the camera.

    It had been sitting in the back of my car, so I think some grit or dust got into the lens. Try moving it to Manual Focus (MF) and zooming in/out manually and focusing manually. My manual focus was stuck - and it was then released. Now when I went back to Auto Fcus (AF) it works again, good as new. FWEW!

    Before that it would only take a photo randomly, wasn't focusing automatically, and the red-eye flash was going off for some reason even though it's turned off. All problems are better now but the red eye flash function still happens randomly.
     

Share This Page