Rebel 2000 "battery check" problems

Discussion in 'Canon EOS' started by cornicello, Feb 13, 2001.

  1. About 2 years ago I got a Rebel 2000 as a backup body. Before I finished the first roll of film it died. When pressing the shutter button the battery check symbol would flash and the shutter wouldn't fire. I tried 3 sets of batteries (different brands in case it was a contact problem with the battery size). No luck. Returned the camera and got another body (from another dealer) and the vertical grip (which uses AA batteries). That worked well the few times I used it.

    <p>

    I'm leaving on a trip and decided to take the Rebel, so I took it out of the closet (hasn't been used since July) and tried it out. And I'm getting the same "battery check" failure. Tried new sets of batteries. Tried different lenses (all Canon, I've seen this issue with older non-Canon lenses).

    <p>

    I remember a similar sounding situation with some Elan cameras. Wondering if the same thing might be going on with the Rebel 2000s.

    <p>

    JohnC
     
  2. On EOS cameras, the dead battery symbol flashing is also an indicator
    of camera malfunction. I've seen it do it when the shutter has been
    damaged (i.e., someone poked a finger through it), and also when
    there is an internal electronic problem. Not a good thing. Unless
    it's the shutter blades and someone at your local camera store knows
    how to pop them back in place, the camera will have to go to an
    authorized Canon repair facility.
     

Share This Page