Problems with Mamiya 645 advancing

Discussion in 'Medium Format' started by alexkane, Jun 10, 2020.

  1. Hello everyone, I am new here on this forum, and also new to shooting Medium format. I just bought a "like new" mamiya 645 pro on ebay and received it yesterday. I went out shooting with a roll of Portra 400. I took my first shot and everything was fine except the camera did not wind to the second frame. It locked up and would no longer fire the shutter, it just makes a faint click sound.
    I have tried a lot of different things, like cleaning the electronic connections, and resetting the mirror/ shutter by holding the tiny lever next to the mirror when the lens is off and firing the shutter. Still no luck, it just gets stuck after frame one. I tried taking some snaps on multi mode with the film-back off and it seems to be working just fine. The shutter stays open the appropriate amount, and the curtains open and close. I am thinking it may be the lens back?

    Anyone else had a similar experience?

    Thank you!
     
  2. That seems to be a common problem with the plastic-bodied M645s. I've had one 645 Super and a ProTL fail in exactly the same way. It could be the wind-on mechanism being out of alignment, or due to the release solenoid coming loose on its mountings. Either way it requires extensive dismantling of the camera to fix. When you gain access to it, the solenoid simply needs a screw tightening and some adhesive applied to prevent it working loose again - something that Mamiya should have done in the first place!

    Really, I advise you to return that shoddy Mamiya for a full refund, if possible. I've had nothing but grief from my 2 'Supers' (nothing super about them) and a ProTL. Get an old metal-bodied M645 instead. They're infinitely more reliable and durable.
     
    Last edited: Jun 11, 2020
    cameragary likes this.

Share This Page