Problems with D70 (CHR error)

Discussion in 'Nikon' started by mikedami, Nov 9, 2005.

  1. Hallo,

    I have a little problem with my 6 months old D70:
    When I shoot, I get sometimes (CHR or CHA) error information. It
    occurred for first time two months ago. I looked in manual where it
    is said, that there is ERROR with access to the CF card.
    Every time it happens I turn camera off and on, and the problem is
    solved. But problem is that it happens quite often, so that I missed
    some good shoots.

    I have old firmware. Would the new firmware solve the problem or it
    is something wrong with the camera or even the CF card (SanDisc
    Ultra II 1GB). I transfer images via card reader, where I newer had
    the problem with this CF card.

    Thank you in advance for your answers.

    Best regards,
    Mihail
     
  2. I've had the same thing but it hasn't happened again for a while. It happened a lot at a time when I couldn't afford to be without the camera so couldn't send it to be checked. I thought it was an issue with a new CF card I'd bought at first, but then it seemed to do it sporadicaly with the other card I was using too. I read up on it being a card error but it never seemed persistant enough to be a bad card or two bad cards. The turning on and off trick worked every time too.

    Using 2 different Sandisk extreme iii 1gb CF cards and I had installed the new firmware too [so that doesn't fix anything if its a firmware issue].

    Hasn't happened for a few months now but it is worrying.

    Anyone else?
     
  3. Mihail: I have 3 D70's, and find that it's not unusual to get a "CHA" error every once in a while (perhaps 1 every 1000-2000+ shots). As you stated, turning the camera off and on clears the error.

    I have no idea if a firmware upgrade would have any affect on that particular problem, but since the upgrade is free and easy to perform, you may want to do it anyway.

    If the problem happens often enough to make you miss shots, consider buying or borrowing another CF card to help troubleshoot. If you determine the CF cards themselves are fine, you may want to take advantage of the warranty and send the body to Nikon Service with the problem description: "occasional CHA error".

    I had the same problem with one of my D70's and, other than outbound shipping costs, it was a no charge repair. Camera works perfectly now.

    Best regards, Dennis
     
  4. Alice and Dennis

    Thank you for your answer.

    I will borrow another CF card, and will see if this is a problem. Few minutes ago I sent mail to Nikon and we will se what they are going to say (If they will answer).
    Otherwise I will wait a little bit, if the error disappears as in Alice's case.


    Best regards Mihail.
     
  5. I just discovered the same problem the other day with my 6-month-old D70. However it was not intermittent. I got a constant CHR error with two different 1GB CF cards, one of which is brand new. (BTW, I tested these cards in a different reader and they worked fine.)

    I found a 64MB card that did work in the D70 and used it to upgrade the firmware to version 2.0. Since I did that, all three of the CF cards (two 1GB and one 64MB) I tried seem to be working fine.

    The new version also corrects a file system error, so if you use the RAW or RAW+BASIC modes, you now have more exposures at your disposal.

    I have no idea what caused this card error in the first place. But if anyone has any idea, please post it here.
     
  6. Matt,

    I also upgraded the firmware, but did not have a lot of time to test it. I took only about 30 shots, and the problem did not occur. I hope it is going to stay that way.

    Best regards, Mihail
     
  7. I have just experienced this issue (prior use for over 1 year had no occurrences) - last night at a wedding reception (use of the camera 2 days prior was without incident). I have tried 5 different CF cards (each of which works in my Coolpix 2100). I have cleaned the contacts. I have the latest firmware. I have formatted each card in the D70 (as opposed to in the PC). I am now basically without use of my D70 (again - as it was just in the shop in July for repair of the BGLOD problem). I have logged a trouble ticket with Nikon and will be sure to let you folks know what they say.
     
  8. I have a 6 month old D70s and am also getting this error [CHA] so i don't think it's a D70 firmware error (unless the D70s happens to have the same firmware fault) Switching on and off works for a while but not for long, have also formatted the cards through the camera too, I'm using a 1gb CF type 1 and a 2gb CF type 2 cards. both getting this error.
    I've submitted a report to Nikon, just waiting on a response. very irregular, it happened about 2 months ago, cleared up on it's own and last night reappeared...
    anyone had any luck figuring it out?
     
  9. Hi I just registered to put a message here for this problem.
    I found a japanese website, were the answer to this problem was posted with pictures but unfortunately I can't find this site anymore. However I found another similar approach to the problem. Most likely this problem is caused by some very flat cable (ribbon) inside the camera that is somewhat loose. Solution for me was to carefully open the bottom of the camera and push the ribbons into their sockets ( connectors).
    Following website has a link to a similar approach only he had a bend pin in the card reader inside the camera. Good luck with this repair
    http://blog.stephanmantler.com/d70s-camera-repair/
    Greets
    Jeroen
     

Share This Page