Problem with the 40D built in flash

Discussion in 'Canon EOS' started by nickjeftic, Nov 15, 2009.

  1. Hi everyone! I decided to post this question in the PN forum before I go and pay 50 euro for asking the same at the Canon Service.
    I was shooting an event on Saturday with my 40D + 580EX II when the battery ran out on the flash. I took it off to reload the batteries and in the mean time take a few shots using the camera's built-in flash but it would not open. I went into the settings menu only to find that the probable cause was that the camera had registerd that the external flash is still on!
    Anyway, to make the story short, I finished the shooting (with the external flash) and afterward tried several times to open-close the camera and flash but the Menu Setting stayed permanently set as if the External Flash was on.
    Has anyone had a similar experience? Any suggestions, aside from the obvious 50 euro visit to the Canon Service?
     
  2. Did you check the microswitch under the rail of the hot shoe?
     
  3. What Mark said...
    There is a little pin that does/can get stuck so the camera thinks the flash is still mounted.
     
  4. Mark, Peter... I'll check it the first thing when I get home and I'll tell you! Thanks guys!
     
  5. IT WORKED! Thanks guys! Next time you're in Athens the beers on me!
     
  6. Glad that was it, Nick. I probably won't get to Athens soon, so I'll hoist one for ya at the local pub! You do the same!
     
  7. You bet mate! Cheers...
     

Share This Page

1111