Printer Epson R2400 and Mac OSX 10.5

Discussion in 'Digital Darkroom' started by domenicopescosolido, Oct 28, 2007.

  1. Hi,

    Anyone know how to set the driver of new Leopard Mac OS in order to get fine quality prits from Epson
    R2400? Unfortunatley I obtain only prints like draft in any way that I set the driver but before the OS
    upgarde I had excellent prints.

    Thanks
     
  2. Mac OS 10.5 has eliminated the printer set-up program and has instead incorporated it
    into the print dialog window. Try reloading your printer driver by selecting the "add
    printer" selection from the print requester box. Go to print something by choosing "print"
    from the menu and it will pop up.
     
  3. The print dialog has been simplified, but all your same driver settings are there.

    I'm not in front of my Leopard machine so I can't give an exact walkthrough, but it's just a
    matter of pulling up the Epson "Print Settings" entry in the print dialog like always.

    Depending on how you upgraded (Archive and Install), you may need to install the print
    drivers. If you did a straight Upgrade, everything should still be working fine. Keep in mind
    that, as always, the available quality options will differ based upon the paper type you've
    selected.
     
  4. Thanks a lot, I'm going to do some test. I had on my Mac also QuadRip that I didn't use but after the OS upgrade it has been upgraded too and I don't know how remove (the old unistall doesn't work anymore): do you think that could be some problems?

    The prints that I obtained untill now are washed like a draft with few colors, and also the panel control to check the levels of inks I cannot find even if I have all inks full (checked before the OS upgrade).
     
  5. Unfortunatly every test failed. It's look that every change inthe Print Seting doesn't have any
    effect in the print: the printer finish an A4 photo print in 1 sec. with a dirty washed quality.
     
  6. Only way I found to restore the print settings is to uninstall the incorrect print driver. The way to do this is download the incorrect driver again, go through the install process. When you get to the dialog box that says easy install, click on it. This should be a drop down menu and it will give the option to uninstall. This will remove the driver files. Just install the Intel driver after that.
     
  7. The Epson site drivers do not work in this case . . . the 2400. So support will follow? and
    when?
     
  8. Domenico
    I am absolutely at the end of my patience with Epson and Apple.
    I have a major project to do and cannot use the R2400.
    Have you had the problem resolved, if so could you tell me how?
    Thanks a million

    Paolo Totaro
    Sydney Australia
     
  9. I have the same issue and have not found an answer. Totally disappointed - I have not lost
    hours, I have lost days on this problem. My R2400 is now plugged into my windows
    machine. I am so disappointed - Leopard really was not ready to go - they should not have
    forced it. I have a laundry list of problems with the OS - printer problems, print share
    problems, windows share problems - cant see the drives, midi problems, I have a list of
    about 15 big items. If anyone finds the answer to the Epson printing issue, please post it.
    Neither Apple nor Epson have been helpful. They are all cordial and polite, but no one has an
    answer.
     
  10. Finally figured it out after spending literally days on this problem.

    Read this post first:

    http://discussions.apple.com/thread.jspa?messageID=5862672

    The key for me was to totally get rid of the old epson driver. I had the Epson Stylus Photo
    R2400 - GutenPrint v5.1.3 driver. It produced horrible washed out results. Photoshop
    could see the printer, and actually printed images, but they looked washed out. After
    replacing all the inks, and running numerous test prints - after switching it to my windows
    machine and back, I finally got it working. Follow the instructions on the post listed
    above. The part where they have you "repair permissions" did not complete for me.
    Something happened and the process just aborted. Why that happened I do not know.
    Once the old drivers were off, I went into system preferences/print & fax. I plugged the
    printer back in. I added it with the newly downloaded and installed driver from Epson.
    When I could select which driver to use I DID NOT USE the GutenPrint driver. This time I
    was prompted to use an Epson SP R2400 driver. I printed a test page - all looked ok. I
    fired up Photoshop, and voila - my gorgeous prints on my fantastic Epson R2400 are
    back. Man I was a real unhappy camper for the past 7 days. So I am back in business.

    Good luck - hope it helps.
     
  11. Steve : I followed the post, but was unable to located the Epson SP R2400 driver and was still
    stuck with the Gutenprint v5.1.3. Can you help out at all?
     
  12. I just recently was able to get the Epson Stylus Photo R2400 - GutenPrint v5.1.3 driver to
    work: I found out that under the "print features" tab there is a tab called "resolution". By
    default this is set to "Automatic". This tab needs to have an actual select DPI other than
    Automatic. I found that if I printed with a 2880x1440 DPI I was able to print beautiful
    picture - just like the printer should.

    I did this without uninstalling/re-installing anything.
     
  13. Hi and especially to Steve Campbell.

    I followed your advice and downloaded and installed from the Epson web site the R2400
    print driver. Hey presto it works. Did a test print and I'm up and running. Cheers, from
    reading everyones comments this saved me hours of pulling out my hair ( which
    I have very little), kicking the dog(so to speak), swearing and thinking what the hell am I
    doing wrong.

    Once again Steve cheers
     
  14. help! I have the same problem I've already downloaded the correct drive from epson
    (6.12). (I followed all the steps from the link above)
    with a funny detail... if I use the easyphotoprint from epson the prints are ok! but not in
    the photoshop. what is going on? please...
    and.. sorry about my english, anyway. I can't find a portuguese site to help me.
     
  15. I have the same problem and feel like I've tried everything!
    Done the Apple recomended removing the old drivers thing, even tried several different drivers from different Epson countries. All the same strange purle pink cast.
    It ws working perfectly until I upgraded to leopard
    Any ideas? Intel Mac pro, CS3 and CS4...
     

Share This Page