Praktica BCX + 50mm F/2.4 - problems

Discussion in 'Modern Film Cameras' started by 33Lima, Sep 3, 2017.

Tags:
  1. Before 'going digital', my favourite film camera was a Praktica BX20 which replaced a Zenit 12xp about 1989. I chose the Praktica largely as it was inexpensive and got a 'best buy' rating in 'Which Camera?', having some features lacking in more expensive Japanese cameras of the same general spec. I traded it in about 6 years later for a Minolta Dynax AF which died completely after much less use, confirming my suspicions that gadget snobbery and lower margins account for much of what you still hear and see about Praktica failure rates.

    Anyway, I have re-aquired a BX20 which seems fine after about 25 years after it was made, likewise a BC1. My third venture was an 'untested' BCX in good general condition with flashgun, and 'pancake' and zoom lenses.

    The camera and pancake lens both have faults and I was wondering if anyone could offer advice. Sorry in advance if this is the wrong forum or I haven't been able to find an already posted answer. I have looked elsewhere, including this most interesting BC1 disasembly guide: Praktica B series disassembly

    First, the problem with the camera itself, a nice aluminium-cased specimen of the BCX with very little visible wear and tear. All seems well, except that the electronics are on as soon as the battery is inserted, if any lens is present. The 'Under' LED flashes - this is with no film loaded, whether the shutter is cocked or not, regardless of lens or aperture etc. In 'Automatic' (AP) mode, if I half-press the shutter release to activate the electronics and check exposure, the LED indications function normally - ie the 'Under' one stops flashing and I get the appropriate LED indication for the light conditions. Similarly, if I switch from Auto/AP to a specific shutter speed for manual mode, I get the appropriate LED display, as described in the B series manuals.

    The shutter release button seems to 'spring up' normally, as far as on the BC1. Turning the locking collar makes no difference, I still get the flashing 'Under' red LED, regardless.

    The offending LED stops flashing if I set the shutter speed dial to B, or to the flash setting.

    Subject to actually putting a film through the camera, it seems all I need to do is remember to 'turn off' the electronics by keeping the shutter speed at B or flash. And I'm in the habit of switching off digital cameras between taking pictures anyway. So if this is indeed the only problem, it seems entirely manageable, though if there is an easy solution it would be good to end the irritant and have it working the same way as the BX20 and BC1. I could remove the top and maybe check for a switch or linkage for the shutter release that is not quite cutting off the power, but I'm loathe to embark on that just on speculation and for a problem that seems to have a simple workaround.

    As for the lens, the 50mm F/2.4 that came with it, the problem here is that it is producing erratic exposure indications. Most commonly it seems to be displaying about 2-3 stops under the correct shutter speed in Auto. Opening the exposure a stop or two while metering can sometimes produce a dramatic increase.At other times but rarely it can seem to produce a credible setting.

    On 'Manual' the LEDs report the set shutter speed correctly (except that 125 is reported as 250) but again, the recommended speed is about 2-3 stops too low.

    'Erratic' is about the best description. I can#t detect a pattern. Increasing the film speed setting does seem to produce the appropriate change, though. Same behaviour on the BX20 or BC1 bodies, with this lens only. The lens seems otherwise to function correctly. I have tried cleaning the three contacts on camera body and lens to no particular effect. The lower of the three spring-loaded contacts on the lens doesn't sit quite as proud as the other two when fully extended but I think it's far enought out to make contact.

    There's a plastic circular insert at the back of the lens with a sort of lug that looks like it's meant to cam the stop-down lever on the camera body, which none of my other three PB lenses have. It's easy to remove this plastic ring and it exposes a little of the mechanism but no sign of anything wrong. It also exposes three screws that look like they would release the rear of the lens and enable me to see a bit more, eg if there was a problem with whatever linkages or contacts there were with the aperture ring.

    Any ideas or suggestions would be most welcome - TIA!

    Moderator Note - Moved from Beginner Questions Forum - placed here for a more targeted readership
     
    Last edited by a moderator: Sep 3, 2017
  2. m42dave

    m42dave Dave E.

    Hi,

    I don't have a BCX, but I do have a BX20. My camera works well, though exposure is off by about 1 1/3 stops when using PB lenses. However, if I use the PB-M42 adapter with screw-mount lenses, it indicates correct exposure with stopped-down metering.

    As I recall, if you remove the lens mount on the BX20, there are additional contacts inside that may need cleaning. You can also check for any loose wires in the mount as well. Hope this helps a bit.

    Dave
     
    Last edited: Sep 4, 2017
  3. m42dave

    m42dave Dave E.

    Also, I'm not sure about the PB lens internals--but on the older Pentacon Electric M42 lenses, aperture information is transmitted by means of a contact wiper which runs along a carbon resistor strip. If the wiper is dirty or the strip gets worn through completely, this can cause erratic readings as well.
     
    Last edited: Sep 4, 2017
  4. Thanks Dave! Apart from the irritating-but live-able issue of the electronics not completely turning off unless shutter speed dial is set to 'B', the BCX seems fine with my other three PB lenses (all zooms). So I'm thinking your second tip is along the right lines, and that as the pancake lens isn't really usable in its current state, it'd be worth a try dismantling the rear to see if I can find any issue with the mechanism, whatever it is, that transmits the aperture setting from the aperture ring to the relevant contact(s) on the back of the lens. I'll have a look on Youtube for lens disassembly videos, I think there may have been one on PB lenses.
     
  5. OK I've found what's almost certainly the problem.

    I levered out the small plastic inner ring/spacer from the rear of the lens as before, exposing four small crosshead screws around the flat inner face of the shiny metal rear of the lens, that mates with the lens mount on the camera body. These screws were removed and the shiny metal mating ring was removed.

    This exposed a black metal ring retained by another three small screws, to which the three spring-loaded contacts were fitted, and a small metal ring that operated the DoF preview. Two of these screws were rather tight but they all came out. I lifted the black ring carefully in case the three contacts were released and flew off but they were fixed to the black ring, which was held to the body of the lens by a green wire which ran from one of the contacts to a folded brass contact wiper.

    The rear of the ring had a dark contact strip which I took to be the fixed part of the mechanism for transmitting aperture setting. The moveable contact was the folded brass wiper which run on the lower face of the contact strip. This wiper moved with the shutter ring, which tended to confirm its function.

    Inspecting this wiper revealed that it was loose. It had been retained by two (plastic?) rivets. These had sheared. You can just about see these, under my rather grubby thumbnail, which is holding up the folded brass contact wiper.

    P1050393s.jpg

    Next step is to glue this back, then put everything back together and see if it works!
     
    Last edited: Sep 4, 2017
  6. m42dave

    m42dave Dave E.

    Good luck and hope this works for you. Thanks for posting too as this is a good reference. Actually I no longer have any PB lenses, and just use my BX20 with screw-mount lenses.
     
    Last edited: Sep 4, 2017
  7. Thanks, Dave, your tip gave me the confidence to open her up! I'm waiting for the glue to develop enough strenght to re-assemble the lens, and will report back if it worked - fingers crossed!
     
  8. OK, that seems to have worked - LED indications are now as they should be. Thanks again for the tip, Dave!

    I think I'll leave the BCX alone, for now, as dis-assembly is a bit more complicated and the risk of messing up something higher, when the camera appears to work perfectly well if I remember to switch to B, to turn her off fully. Happy to get the duff lens fixed!
     
  9. I think the B-series Prakticas were mostly well designed, but my experience over the entire Praktica production is that the L-series were the best made.

    I find that the B-series seem to be a bit "fragile". Actions like advancing the film should be done evenly and slowly. Praktica-B-set-2.jpg
     
  10. Nice collection there JD! About the time I got my first SLR (about 1984) I somewhat regretted choosing the Zenit 12xp over the MTL5 which I also saw demonstrated - I think because a shop had a Zenit kit at a decent price, a friend who had a Zenit TTL recommended one, and the 12xp had LEDs rather than the somewhat harder-to-see swinging needle on the MTL5 (the 5b and 50 got the LEDs IIRC). Not that the Zenit was a bad camera, it wasn't, just that the MTL seemed a somewhat better one.

    So I never had a screw-mount Praktica - but I will get one at some point - possibly a 5b or 50 as I gather they take batteries that are still available - and an adapter so the B series can take any screw mount lenses I get. Is there any particular M42 Praktica would you recommend?

    As I mentioned above, it was my darn Minolta Dynax which died on me after a couple of years of fairly light use. My original BX20 never missed a beat over 6 years or so. It's still my favourite, and I don't find it any more 'plastiky' than a Glock compared to a Browning to take a 9mm rather than a 35mm example :) And the 'shutter cocked' viewfinder indication and TTL flash were welcome and useful, compared to earlier B series cameras (and to many of the supposedly so superior but certainly pricier Japanese competitors). However, I was pleasantly surprised to find that even without the BX20s handgrip, the BCX and BC1 feel at least equally good in the hand - the lens mount being closer to the right hand, for a non-southpaw anyway, means the earlier types are actually better balanced, for me anyway. Perhaps a Jenaflex AM or a bC3 should be next... :)
     
  11. m42dave

    m42dave Dave E.

    Here is a Praktica BCA I disassembled. Plastic outer coverings and parts, but a solid metal chassis underneath, and seems well made. Shutter is similar to the L-series.

    The Pentacon 50/1.8 M42 is always good to have--close focusing to 10" and an auto-manual switch.

    Praktica BCA Disassembly.JPG
     
  12. I'm not sure I want to see any of my Prakticas looking like that, Dave :)

    Do you remember, if there was anything about the shutter release that looked user serviceable - something that might be sticky and be able to be freed up so that my BCX didn't display any LEDs until the shutter release was properly half-depressed? Like a contact that was being made prematurely, or where a short-circuit dould develop, that sort of thing? A blown-up view of the shutter release area on that pic may be helful, if anything of the mechanism was visible. Still, I'm not at all sure I would fiddle with the BCX unless a more serious problem forced me to take the risk.
     
  13. m42dave

    m42dave Dave E.

    Sorry, I don't recall as this was a while ago and I no longer have this body or any other pictures.

    Here is a link with information on removing the top cover of the BCX:

    The Praktica BCX project
     
  14. Thanks Dave. Nice camera, the silver BCX; think I'll leave mine well enough alone, for now, a.k.a getting out while I'm ahead :).
     
  15. My favorites are the VLC models (removable prism, etc.) in the L series. They were inspired by the last of the eastern Exaktas.

    But the models most likely to work well out of the box are the L and L2 plain models with no meter (that's what usually goes first, although the meter batteries are usable at voltages other than nominal on the Prakticas as a rule).
     
  16. The VLC was actually one of the earlier TTL metering systems.

    Praktica-VLC-Photokina-1974-11-PP.jpg
    Popular Photography 1974-11

    Praktica-MTL5.jpg
    My MTL5 - "What ever happens do not fear, we'll keep the old flag flying here"
     
    Last edited: Sep 8, 2017
  17. Altogether, now:

    "Though Contax flinch and Nikons sneer
    We'll keep the Pratkicas snapping here!"
     
    John Farrell likes this.
  18. ... thanks (more than two years later); I encountered the same problem with a Praktica BX-20 and a Prakticar 50mm f / 1.8 lens, I first suspected the Praktica BX20 camera, but when testing that it worked with other PB lenses and checking that it worked I came to the (obvious) conclusion of that the problem was in the objective, in which I verified that the support of the three transmission contacts of the automatism was sinking and was not very firm. Searching then, I found your post confirming my suspicions. I more or less understand the process of disassembly and repair, but, you would not be tedious and could you send me some more photographs of the disassembly and repair that could guide me. I understand that after this elapsed time that is not possible. In any case, thanks for sharing your experience, only that has been a great help.
     
  19. ......repaired (and running) the Prakticar 50mm f/1.8 lens; the mechanism is very similar; In my case, the transparent plastic support where the three contacts of the Prakticas B automatism had been embedded is broken. I stuck the remains of the support in place with Araldit and it seems that it resists. Thanks 33Lima.
     

Share This Page