Praktica B100 - film advance lever stuck

Discussion in 'Modern Film Cameras' started by sandrasome, Oct 18, 2017.

  1. Good morning,

    I have a new camera, a Praktica B100 and it was apparently working perfectly but I don't know what happened that my film advance lever got stuck and I don't know how to make it work again. I will post a picture to show until where it can be moved, but it can't go further that that and I can't take any photos since it doesn't work.

    Thank you! l8Jd-Z6d.jpg
  2. Tony Parsons

    Tony Parsons Norfolk and Good

    Have you reached the end of the film (24 or 36 exposures) ? If so, the lever cannot advance as there is no more film to be wound on. Rewind and remove the film, and try 'dry-firing' it, to see if it works then. If it does, problem solved - if not, then it needs service or repair.
  3. I tried to do that but it's still not working. Could it be a problem with the battery where I just have to change it or I just need to take it to repair?
  4. It's a long while since I used one of these but I think they are completely battery dependent, so the shutter won't operate and the winder will lock if the battery is dead. There's a battery check position on the control dial - the needle in the finder should move to the dot by the 1/250 speed when you operate the battery check. If it doesn't it needs a new battery. There's a copy of the manual here:

    Good luck
  5. Thank you very much! I will buy a new battery and see if it works. Hopefully it will.
  6. I'm afraid I haven't loaded up the old B100 for a long time, but I do remember very clearly that the wind-on mechanism on the B series is very sensitive to quick and harsh use. Mine jammed up on occasion when I didn't exercise caution and a slow touch on the lever.

    Good luck
  7. This is a really long shot, but is the rewind release button - the little silver disc on a shaft, in the U-shaped recess in the rear of the bottom plate, on the RH side (viewed from rear) - fully extended/down? So that the disc is nearly down level with the bottom of the camera, exposing about 2mm of its shaft above the disc? If it is not, but is pushed up, I wonder if that could be interfering with the rewind action? If the rewind release is in the pushed up position, it might be worth seeing if VERY gentle leverage with a wooden toothpick or similar, not a metal object, can ease it back down. Unlikely to be the problem I suppose, as I believe the winding on action itself is supposed to disengage the rewind release, but that in turn suggests the two items do have some sort of internal linkage, which might have got stuck somehow, eg winding on while inadvertently pressing up on the rewind - so it maybe worth a (gentle!) try. Avoid using any force or a lever like a screwdiver tip.

    Battery makes no difference, as these cameras will operate (wind on and fire shutter) to a fixed shutter speed without one.
    Last edited: Oct 26, 2017
  8. It may be that your B100's mirror is stuck - it looks to be sitting a bit high. There should be a gap of maybe 4mm between the lower edge of the mirror and the sort of black shelf that forms the base of the rectangular housing in which the mirror swings.

    If it doesn't look like pics you can find online of a B series with the lens off (I'm not able to post one here), you might want to search for a solution for a stuck mirror on a Praktica B series camera, or maybe others here could advise.
    Last edited: Oct 26, 2017

Share This Page