Pentax 67 wind lever problems.Need Help!!

Discussion in 'Medium Format' started by goncalo_martins, Oct 17, 2006.

  1. Hi

    I just bought a pentax 67 with a TTL prism.

    When i was loading the film according to the manual..everything went right,and
    when i close the camera back for turning the wind lever until the counter
    indicates "1"...i did turned about 3 times, then instead of "1" it appeared the
    number "5"...and in the next turning that i did (because i was confused), the
    wind lever got stucked..and want come back to initial position.

    I took the film out..thinking that it would resolve the problem...but it didn?t,
    then i tried to use the safety device release button...but nothing happened.So
    i've got my wind lever stucked...and i don?t know what to do!!

    Please help! Hope this is a minor problem.. :/

    Thank you
     
  2. Some questions:


    1. Can you press the shutter release and then advance the wind lever?


    2. Is the shutter open? Can you look through the view finder and see anything?


    3. Have you tried putting a fresh battery in?
     
  3. 1. The wind lever isn?t in his initial position..it's stucked on the end

    2. The shutter is opened.when i attach a lense i can see through

    3.The battery is ok..The light gets on when i check the battery
     
  4. I don't know what you can do at this point, except send the camera in for repair. By the way, if you search this forum for "wind", you'll find that several people had problems with the wind lever on the Pentax 67 and 67II. It may be worth reading those threads to see if you get an idea about how to fix your problem....

    Sorry I couldn't be of more help. The only time my Pentax 67 (built in 1981) has this problem, I think it was battery related....
     

Share This Page