OM-4Ti & Winder 2 incompatible ?

Discussion in 'Olympus' started by ondrejp_spyderman, Jan 10, 2007.

  1. Here's the case: I have OM-4Ti and Winder 2.

    Together it behaves very strange... In single: One push of release on Winder -
    it fires shutter, second push - it winds the film. Holding the release on Winder
    for longer doesn't help. I still have to push it second time to advance film.
    In sequence it advances then fires and stops. Not fires and advances, but
    advances and fires.

    Then when I mount Winder on OM-20(G) it works as supposed: sequence fires
    continuously, single fires and advances.

    Contacts on body are clean, so I'm asking: is there some incompatibility? or is
    this just my OM-4Ti body?

    (I don't plan to use the winder anyway, so it's not a big deal. I'd just like to
    know...)
     
  2. Sounds like a classic OM "combination problem" where certain drives will work with certain bodies on certain days only. There is a switch on the bottom of the body that can get out of whack. I had the same problem on an OM-2S. You need to have the body serviced.
     
  3. it's SUPPOSED to work......
     
  4. I have used both Winder 1 and Winder 2 with my OM-4Ti without compatibility problems.

    regards
     
  5. The problem is solved. The winder now works flawlessly...

    I just removed the bottom plate, checked the movement of various copper contacts, replaced the bottom plate and suddenly it worked. So it was just a bad contact...
     

Share This Page