OM-2n can't select shutter speed in Manual

Discussion in 'Olympus' started by markus9229, Jul 9, 2020.

  1. So I just adquired this minty OM-2n, it's in beautiful condition and everything seems to work, except the Manual mode.

    Basically the manual mode acts exactly the same as Auto mode. It doesn't care what shutter speed I choose, it will fire according to the light it's receiving.

    I bought 2 new SR44 batteries by Duracell to see if this fixed it but it doesn't. Same result (but accurate readings on the needle).

    The mode selection lever works as intended since I can see the change in the viewfinder when I go through all the 3 modes, and the Bulb mode works as intended too.

    I searched everywhere and noone seemed to have this specific problem except 1 video on youtube that was posted a decade ago.


    I paid quite a bit for this camera (imported from Germany) because it's in such nice cosmetic shape, and I also live in a small town with no repair shops around.

    Do you guys have any idea of what I could do to fix this?


    Thank you.
     
  2. Not a fix but a way to possibly find the trouble. If camera is in auto mode or any manual shutter speed except B tripping shutter without battery locks up mirror. Remove battery and set to B. If dial is working shutter should open. If mirror still locks up then dial is not responding.
     
  3. I have two things to try.

    The first is to operate the switch, - turn it back and forth among the positions many times. Sometimes the contacts get dirty and don't work correctly.

    The 2nd thing to try is more of a diagnostic.

    The OM-2 has an interesting feature. It works in "Auto" mode when it's turned off, but only to a certain extent. The slowest the shutter will go when turned off is 1/30. The reason it works this way is so that you can get that quick shot off if needed. Of course if the film isn't advanced you'll still be out of luck.

    Anyway, if you set the switch to manual and fire the shutter in a darkish room, does it fire really slowly like it would in auto mode? Or does it fire at around 1/30?

    Either way it sounds like the switch isn't working right. If you've ever had the top off of an OM-2 you'll see that there are number of contacts on the switch that press down on a circular pattern of corresponding copper traces. Those contacts could easily be bent and both the contacts and the traces can get dirty. Manually cleaning them might fix your problem. I've had multiple OM-1 cameras whose meters worked only sporadically because of dirty contacts. I'm guessing and old OM-2 might have similar issues.
     
  4. Hi,

    Did you get this sorted?

    Kind regards
     
  5. Try this: remove the bottom cover and watch as you move the mode switch back and forth from Auto to Manual -- you should see a small arm on the bottom of the camera move back and forth, pushing a tiny arm as it moves. That tiny arm operates a switch on the main circuit that selects Auto and Manual. It could be that that small arm isn't moving back far enough when it's moved to the Manual position -- someone may have accidentally bent it. You might try bending the end of that lever a tiny amount in the direction it moves when you select Manual mode, then replace the bottom and check.

    If that isn't it, it could be that the manual contacts on the main circuit are not making a good connection -- that should be included in a typical overhaul, but it's not something I'd suggest for DIY!

    Of course, there are other possibilities too intricate to describe -- only inspection by someone who knows OM's could tell!
     

Share This Page