Olympus TG-4 shuts off seconds after turning on

Discussion in 'Olympus' started by tholte, Jul 16, 2018.

  1. I contacted Olympus with my problem and they say it is probably a short circuit. It is not under warranty and they are quoting me $143.00 to repair which is half the price of a new one. I didn't use this camera much and never got it wet. I am not going to send it in for repair but am wondering if anyone on PN has any ideas? Thanks for any responses! Yes I did recharge my OEM battery and bought three more and still no go. I can't get in to the menu because the power only stays on for about ten seconds. I thought this camera was supposed to be "Tough"!
     
  2. Does anything display on the screen in that ten seconds ?
     
  3. Norman 202

    Norman 202 i am the light

    I’ve owned TG-2,3,4 & 5. All owned from new and the only problem I have encountered is the zoom rocker switch going after a week or so on TG-5. Oly fixed it pronto.

    They are tough, I’ve dropped most of mine and they bear up.
     
  4. Yes, what the camera is seeing for five seconds (just timed it) and then shuts off. I am open to any ideas because I am not sending it to Olympus to fix for $143.00.
    Thanks for your response!
     
  5. I thought it was supposed to be tough Norman that's why I bought it. My Nikon D300 and D750 have proven to be much tougher.
     
  6. Norman 202

    Norman 202 i am the light

    I’m sorry to hear that Tim. IIRC, the TG-4 uses a proprietary cable for in camera charging. Do you think that might be the problem? Could you not try charging the battery with a cheap external battery charger? They have them on amazon uk for about £8-10. Probably cheaper where you are.
     
    Last edited: Jul 20, 2018
  7. What I was asking was, is there any text on the screen for the time that the screen is on ? Usually it has something like "Change Battery"

    Do you have a multimeter ? Check the voltage of the battery. If the battery is flat, the charger may be faulty

    If the battery is fully charged, the camera may well have a short circuit and a safety device in the circuitry is possibly preventing an overload, acting like a circuit breaker

    Have you cleaned the battery contacts deep down in the battery compartment in the camera ? There may be dust bridging across the contacts

    If you can't fix the problem without disassembling the camera, I think you would be wise to pay Olympus to fix it, $143 sounds fair
     
  8. There is no text, just the live view and then nothing. I will get another battery charger to see if that is the problem. I will try cleaning the contacts also to see if that works. Thanks again for the tips. Will let you know what happens.
     

Share This Page