Olympus OM10 blocked in bulb

Discussion in 'Classic Manual Cameras' started by cristina11, Jul 11, 2018.

  1. Hello

    I'm quite new here. I have recently bought an Olympus OM 10 that worked perfectly about halfway through the first film I have tested. Today when I tried to shoot bulb it stuck with opened aperture. Does anyone have a suggestion how can I unlock it?
    Thanks.
     
    Last edited: Jul 11, 2018
  2. Several strategies might work: Remove the batteries and reinstall them. Another possibility would be to set the shutter to x-sync (1/60 second). If the batteries were not fresh a new set might work. The OM-10 is sensitive to insufficient battery voltage.
     
  3. Thank you, I will try with a new set of batteries.
     
  4. What Mike said is right on... I brought one back from the dead .. by installing new batteries and at first it didn't respond to the new batteries, but fiddling with it a bit and then putting them back in a second time and just like Lazarus.. or Jon Snow it woke up suddenly.
    I noticed also that it is susceptible to poor batteries. Also I think it needs the voltage to travel through the circuits if it hasn't been used in the last years or so...ie the caps need to cycle through charge/discharge
     

Share This Page