Olympus Mju III 115 stuck on red eye reduction setting - not shooting

Discussion in 'Olympus' started by shirileewebb, Oct 15, 2019.

  1. Hi there.

    I was using my Olympus Mju III 115 film camera a couple of days ago and accidentally set it to the red eye reduction setting when I was I meant to turn the flash off.

    The camera was trying to take the photo in this setting but sort of got stuck and the exposure did not take, so I slid the cover closed and opened it again. Unfortunately that has now meant the camera is sort of suspended in this mode and not taking any more photos, and the lens will not protrude.

    I have now removed the film that was inside at the time, using the mid-roll rewind button which worked fine so it is empty.

    I have tried to remove the battery to try and reset it but it is still stuck in this mode and will not take a photo.

    The camera will also not load a new film as it thinks it is busy. When I open and close the cover, the camera does make a sound as if the lens is getting ready for photographing, but isn't quite achieving this. The red eye reduction setting is also still showing on the display at the rear.

    Has this ever happened to anyone using a Mju before and did you manage to resolve the issue?

    Would greatly appreciate your assistance!

    Thank you

Share This Page