Olympus 35 EC - shutter problem

Discussion in 'Olympus' started by mwerd, Mar 25, 2018.

  1. Hello!

    I'm brand new to this community and am hoping to find some trouble-shooting pointers for my Olympus.

    I have this dreamy little camera that belonged to my mom when she was a teenager and I've been testing it out with a bunch of issues. The first roll I shot developed blank and I was told the shutter was broken. I didn't realize it needed batteries so I got new ones (now the little light comes on when I go to shoot) and tried a second roll, still blank.

    In testing the camera without film and with the back door open, it looks like the shutter is firing every 3rd-4th shot but was still producing blank film. The advance wheel also seems to let me advance waaaay past the allowed 24 shots of the roll.

    I'm not even sure where to start to try to figure out what's going on here. Any help is greatly appreciated! 15220118796701833026280.jpg 15220119434601201560761.jpg
     
  2. "The advance wheel also seems to let me advance waaaay past the allowed 24 shots of the roll."

    This shouldn't happen - I'd guess that the film is not advancing at all. Either it's not engaged properly with the take up spool, or there's a problem with the film advance mechanism. Sometimes on Olympus cameras there's a slipping clutch on the take up spool which can become slack and ineffective.

    It's always good practice after loading film, to turn the rewind knob back and take up the slack film in the cassette and make sure it's engaged properly, Then when you advance the film you should see the rewind knob turning too.

    This doesn't address the shutter issue but you need to eliminate it first.
     
  3. The 35 EC requires battery power to function properly, but does NOT have any device or mechanism to prevent the shutter release button from operating even if there are no batteries, or if the batteries are dead, too weak, or make a poor connection. In other words, you can wind and "fire" the camera all day without the shutter even opening once! A "release button blocking mechanism in the event of battery failure" was a feature introduced in the EC-2.

    The trick is to be sure you have two good 1.4volt batteries in the camera, the battery contacts are clean, and the battery cover has no corrosion that will short the batteries to the body (see below). This being done, you need to slowly s-q-u-e-e-z-e the release button and watch for the orange lamp through the finder or on the top of the camera to glow when the release button is part way down. If it doesn't come on, there's a problem, and you can't be sure the shutter will open.

    Corrosion due to battery leakage is a common problem with these models (EC, EC-2 and ECR), both in the battery cover as well as under the battery chamber. To check the battery cover, take an ohm meter and press one lead to the edge of the cover and press the other to each of the four corners of the contact. Any reading at all and there may be corrosion under the black plastic insulator. If need be, clean the battery contacts in the battery chamber with a typewriter eraser (ever heard of those?), or even just a plain pencil eraser -- don't scratch! If that doesn't work, there's a good chance the wires from the battery contacts to the circuit board are corroded and in need of replacement.

    Also, there is no "link" between the film counter and the wind, per se. In other words, the only thing that stops the camera at the end of a roll of film is -- the film. Without film inside, you can wind and fire the camera a hundred times, it will just keep going no matter what the counter says. Conversely, if you load carefully, you may get 25 or even 26 shots on a "24" exposure roll of film, or if you are too careful, you may only get 23 or 22 shots before you run out of film on a "24" roll. But whatever you do, don't force the thumb wheel to turn, even if you think you should have another shot!

    Oh, and it looks like the light seal foam along the hinge side of the back cover is done for. You can replace it with any number of substitutes, from black foam material made for cameras, to thin black yarn glued in place.
     
  4. I'll chime in as well on this matter. My OM-1 had a dead circuit issue, which turned out to be 'just' corrosion of wire. I removed the bottom cover, cleaned everything, changed the wire and it worked again. OM-1 used to use same Mercury batteries as EC I believe, so before doing anything else it's indeed a good idea to check for the nasty greenish rust.

    As for the film, if I load it in the dark I can easily go 'way beyond' designated 24 and 36 frames, to 27 and 30 respectively. And if I load the film really carefully, I can even get 28 and 40. But of course it's a 'must' to check winding mechanism either as you've already been told, or doing the winding with already developed film and the camera back open, to see if everything works and film is being transported.

    Rangefinders are generally less sturdy than reflex cameras and even if not, it's always a good idea to service anything that's older than 30 years. Humans included.
     

Share This Page