Not secure!

Discussion in 'Photo.net Site Help' started by Gerald Cafferty, Oct 18, 2021.

  1. To be able to get on the site I've had to tell Chrome to ignore the site not secure message.
    It looks like the site certificate is invalid (seems to happen every year).
     
  2. I've seen that message from several sites over the last month or so. Checked a box called "alway accept" in preferences somewhere...problem is probably still there, I just don't see it any more. Was never an issue with Firefox.
     
  3. I had the same message this morning (GMT+7) but now I have a little padlock next to the photo.net address which suggests the site is secure (I think)

    A049C637-99EE-4811-80D5-436519459F59.jpeg
     
  4. Mebbe not, Chrome is still warning against a missing certificate.
     
  5. Now Firefox is out!
     
  6. The displayed padlock from safari is clearly a bug
     
  7. Seeing the message at some B&H Photo pages.
     
  8. Firefox warned that the certificate expired yesterday, 17 October.
     
  9. How nice, give someone the link to your personal gallery page and they get a un-secure site warning message.
     
  10. Info on web domain SSL certificates. LINK It's going to take PNs Admin to fix this. It is a shame so many nasty folks angry posting in the last years basically killed any interaction with PN Admins here, to the point we get no word from them. I felt bad for them, who would want that job. Sigh...Is there a back up group on Facebook where friends here can keep in touch and regroup if PN were ever to vanish with no word? Not wanting to see this happen, but would be real bummed if it vanished.
     
    ] likes this.
  11. I'm getting that "Not Secure" warning for more than just Photo.net, quite a few different sites as a matter of fact.
    I figured it was my old computer and operating system because other things are dropping out such as some Dashboard and video workings.
    Now I'm reading this thread and realizing it's not just me alone ... but suddenly, in the last 24 hrs, the icons at the top of this panel as I'm
    typing have all disappeared with only blank rectangles showing. I have no idea why that is happening.
     
    Sanford likes this.
  12. I have a contact at CreativeLive, don't know where I got it, but he sees the problem and is passing it along to the proper authorities. I have also had issues with other sites lately.
     
  13. Both my Edge and Chrome just now picked up non-secure from my Kaspersky anti-virus software.
     
  14. Same here with Opera - certificate invalid.
     
  15. argh

    argh Administrator Staff Member

    Certificate updated!
     
  16. That's what I'm seeing.
     
  17. ShunCheung

    ShunCheung Administrator

    After two days, the cert is finally updated.
     
  18. For what it is worth I created a photo.net support group at Flickr in case PN did not come back. Understand I have zero ambitions to create anything other than a place where regular members might find each other and could even open photo threads as we have here if so desired. PS I am not a regular at Flickr as PN is the only photo site I participate on..
     
  19. Good idea. What’s the name of the group?
     
  20. Photo.net support.
     
    luis triguez and Gerald Cafferty like this.

Share This Page