Nikonos Film Advance Lever Cocked, yet Shutter Will Not Fire?

Discussion in 'Nikon' started by katie_pype, Jul 16, 2015.

  1. I recently found a Nikonos II at a rummage sale for a give-away price and just had to have it. It seemed to be in decent shape, shutter was firing and came with a little 2nd edition booklet of "Nikonos Photography - The Camera and System". So I took it apart, realized it had some film in it still. Rewound it and threw it out, gave it a good cleaning and some lubrication on the O-Rings, figuring I could still use it for land use near the water without much worrying. I put it back together and after a few times testing the shutter, the film advance lever is cocked, but if I try to "depress" the shutter on it, the shutter will not fire. It feels stiff, as if it is on the last bit of film still. But I already rewound it! I looked in the little booklet and it only told me to remind the film as the lever is on the last tooth of the sprocket. I've tried rewinding it some more but it appears not to be doing anything. Is there something I am missing to 'reset' it? Or should I just try to keep rewinding it and see if I has any effect? I tried looking up my question here and online, but only found forums for the IV and V, which are electronic. I am going down to the beach next week and I would love to take this camera on the sandy beaches instead of my digital. Any help would be appreciated, thanks!
     
  2. Its been years since I had my II but I seem to remember a lever that rotated down to keep the camera firing accidently. I may have imagined this, but check it out
     
  3. Look at page 15 on the manual. http://www.cameramanuals.org/nikon_pdf/nikonos_ii.pdf
     
  4. I do not have the safety lock on, which is why this is puzzling me. It is fully rotated up and I can depress the lever to try and engage the shutter with some resistance (I don't try too hard), but it seems like it's not moving.

    Oh look, I found the problem! After noticing there was a cover plate of sorts around the shutter mechanism, I figured it couldn't hurt to see what was going on down there. Two little screws and out fell out my problem! It seems as though the frame counter reset button (about a eighth-inch long piece of rubber) fell into the camera and into the shutter mechanism, which blocked something from moving properly. Out it fell and click! I press the shutter and it works, and the lever moves back into it's uncocked position! Make sure everything else is good by running the shutter a few times before screwing the plate back on and putting my camera back together. Glad this one didn't have to go to the 'for parts' section on the Bay! This one will be going into my bag for my California trip! Thank you for replying!
     
  5. A few years ago I found an early
    Nikonos ( early first version) that works
    well. Takes pretty decent pictures no
    matter what the weather and you can
    still buy seals for it and other parts from
    Florida. I bought an original lens hood
    for the 35mm f2.5 which has always
    been a decent lens.
     

Share This Page