Nikon Z6 camera issue

Discussion in 'Nikon' started by tkundu, Sep 9, 2021.

  1. My Nikon Z6 while trying to shoot picture, it is showing [r20] (at the bottom right most area, while half pressed the shutter. Otherwise, it showing [3.1]k. It is not allowing me to take picture. Anyone4 please help me out.
  2. First, I do not have a Z camera; I use a D750. But the display you are writing about is the same for most Nikon cameras.

    When the shutter release is pressed half way, the area on the Control Panel show "r" and the number of exposures left before you fill the camera's buffer. In your case you can take 20 more shots at your current settings - RAW, JPEG, etc. - before the buffer fills and the camera must write to the data card. Until the camera makes room in the buffer, it will not take any more images. You have 20 images left, so that is not your problem.

    The number 3.1k that you see when the shutter release is not pressed is the number of images you can write to the data card before it is filled and the camera stops taking images. You have 3.1 k where "k" stands for 1,000 multiplier or room for another 3,100 images before the data card is full. That is not your problem.

    First, is your subject in focus? If not and if you are in Single Servo with Focus Priority (usually the default selection for Single Servo), the camera will not take a picture until the subject is in focus. Be sure the "green dot", the Focus Indicator, usually at the far left end of the bar at the bottom of the view finder is on.

    Next, try performing a factory reset and see if that cures the problem.
  3. Yup to all the above.

    Could you add some more details about 'won't allow...'? What actually happens?

    What lens are you using?
  4. Agree that the lockout has nothing to do with the number of shots remaining. (and incidentally you must be shooting only JPEGs to get that many shots on a card.)

    Therefore it's got to be something like lack of AF lock. Or maybe a lack of light in one of the auto exposure modes.

    Try setting the ISO to auto, and turn off face recognition, smile recognition or any other focussing silliness.
  5. ShunCheung

    ShunCheung Administrator

    bgelfand has already explained what that r20 and remaining frame counter mean.

    If you press on the shutter release and nothing happens, the first thing I would check is the Custom Setting Menu, group A, Autofocus. If a1 or a2 is set to focus priority but AF is switched off on the lens, when the lens is not in focus, the shutter would not fire.
  6. Does that work like trap focus then? ie, if I rack the focus ring it will fire when it thinks it's in focus if my shutter finger is hard down?
  7. Thank you all for the responses. Few question you folks asked, let me answer'
    - I am using the original Zikon 24-70/4 S lens
    - I am getting r19 error
    - I took pictures 2 months back and reopened the camera and that's when it goes into this state
    Yes I understand the r n represents no of shot remaining and 3.1k is the memory left.
    However, I am sure this numbers are just bogus in this scenario. I changed the battery fullu charged, I see the same error with shutter locked
    I removed the memory card, same display.

    Here is the solution, I found it very hard way. I reset the camera settings, and restart the camera. It came back to life. Now I see r 20. I am pretty sure, this was a software bug the camera, went into a bad state, which persisted and no matter what you do (including on/off, battery, memory remove), it remains in an infinite loop. By the way, I have not done any complicate user defined setting or similar things.
    It is a stupid unsolved software/firmware bug. Nikon should solve.

    Thanks for all your support guys,
  8. ShunCheung

    ShunCheung Administrator

    Again, that r19 is not an error. It is showing the real size of the buffer with your current settings. High ISO settings, noise reduction, etc. may reduce the buffer size (in terms of how many raw files it can hold) so that the r number can become lower, as the camera needs buffer space to process image file under such settings.

    I still feel that it was likely that somehow your Custom Settings were accidentally messed up. A likely scenario was that a1 and/or a2 was accidentally modified to focus priority, such that the camera wouldn't fire when the subject is not in focus. That has happened to me on some Nikon DSLRs, and in this case the Z bodies behave the same way. Once you reset everything, it moves away from that setting and your camera is working again.
    Last edited: Sep 12, 2021
  9. First, congratulations on solving your problem.

    I agree with Shun, and you, that r19 is not, per se, an error code (as I wrote above). However. a persistent r19 when it should be r20 means that for some reason. the camera did not write the buffer to the card and then clear the buffer. It hung either during the write or the clear operation.

    Did your card contain all the pictures you took that day or was the last one missing?

    The glitch could be due to the camera or the memory card. The camera should be able to recover from a write error, but the operative word is should.

    Last questions, what firmware version are you using? And are you using a XQD card or CFexpress card and which brand and card? Is it a supported memory card?
  10. Yes, I have all the picture I took.
    I am using Sony, XQD card. Just curious on one point, if I remove the batter and/or the memory card will it not get the programming running within Z6 will goes off too. When I put the battery back and turn on, it should start the camera program again. If that is true, surely, the camera save some state when we turn off the camera into some internal mos (persistent memory). I guess, that state got screwed up (for some reason). Therefore, the saved state is already messed up and when it get back to life, it goes back to the same messed up state.
    I sill believe, no matter how user of the camera configure it, the software should not hang to a bad state and Nikon should fix this.
  11. Here is the official Nikon explanation about "rxx":

    Here is how to completely reset to factory defaults (you probably already got this): On Setup Menu, scroll all the way to the bottom to find "Reset All Settings". When you are done, you would be instructed to turn off the camera.

    Regarding the inability to shoot in spite of the subject being in focus (?), see if any of these solutions work for you:

    Finally, try the AFC focus mode to see if it works.

    Good luck!
    Last edited: Sep 13, 2021
    tkundu likes this.
  12. If you're getting a message about frames remaining, ie r20, with no card in the camera, then yes it's brain is messed up....:confused:

    Glad the full reset worked.

  13. You have not answered my question about which firmware version you are using. Unless you are using the latest, you have no complaint.

    By the way, I/O malfunctions not only hang cameras, you should see what it did to some of the mainframe computers I worked on. Programming I/O is a tricky business.

    By the way, since you feel so strongly about this problem, Have you reported it to Nikon yet?
  14. - About the version, if this is a kniow problem, Nikon should have already known about this issue and there should be a bug fixed. I am not sure, if latest version usage guarantee that the issue is fixed. NoI have not reported this issue.
    - I/O malfunction (no matter what kind of file-system used) I/O write should return an error code. Based on the error code, the upper layer, in this case the camera application should retry (for few times) then give up displaying the error code/message. Being a software developer for 4 decades and specifically in the fileld of operating system, this is definitely a bug in the software/bug. The infinite loop continues even without memory card (very funny). Programming I/O is buggy, if returned error is not handled properly.
  15. I'm no software developer, but I have noticed most complex electronic devices have a form of Reset.

    Sometimes it's a small button you have to press and hold for a few seconds, sometimes it's a menu selection, sometimes it's a 2 button press reset.

    Point being, they all have one. It doesn't mean they ALL have buggy software.

    Maybe one of your chips got a direct hit from a cosmic particle and it corrupted the code. A hard reset reloads that code afresh, and now it works.

    Your second phrase 'if this is a known problem', is relevant. It's not been reported before and that seems to mean it's specific to your camera, which a hard reset has fixed.

    Nothing for Nikon to fix.
    bgelfand likes this.
  16. I think you are mixing up to situations;
    a) I have configured some setting and I want to reset back to original (I mean factory setting). This is when an user of the camera wants at his/her own will
    b) a code (rather buggy code as I insists to say), due to wrong logic keeps looping, in software term it called hanged. Yes, when you reset the code, it forces the operating system (in camera) tp reboot the code again abandoning what it was doing. This is hard reset.
    Having explaining the scenario, you should now accept this is as a buggy situation. And the hanging loop in the code should be fix (I mean the loop logic).
    Therefore, the statement "Nothing for Nikon to fix" is a very bold yet wrong statement.
    Again I reiterate "The software is buggy"
  17. Sorry, but I disagree.

    You seem to be the only 'sufferer', therefore it's you, not Nikon.

    Think logically, if it's a bigger, wider problem, the internet would be full of it.

    It's not, so make your own conclusion.....;)

Share This Page