Nikon F5 Command Dials Issue

Discussion in 'Nikon' started by nathancraver, Aug 16, 2013.

  1. I have a small, somewhat insignificant issue with my otherwise great F5 and I was wondering if this is common to the F5 or not.
    The issue is, sometimes when I rotate the command dials, for any adjustment they can be used for, both dials seem to quit working for a
    few clicks, then continue working. This happens when rotating in both directions. The dials feel fine, the clicks don't get quiet or feel
    different when this occurs. As an example, when I rotate through shutter speeds, it will change one step for each click, then get to one
    step, then I have to rotate the dial 2,3, sometimes 4 clicks to get to the next step. If I go backwards from there, it will usually go right
    through the steps and do the same thing at a totally different shutter speed. This happens with aperture, and when holding a button to
    make adjustments such as ISO. It happens when I rotate the dials fast or slowly. The issue does not seem to be isolated to a particular
    portion of the dials, so it may not be a dead zone on the dials. It also does not seem to be limited to certain settings such as always
    freezing at 1/500 shutter speed or anything like that. Anyone familiar with this issue and has anyone had the camera repaired for this?
     
  2. I do not have an F5, but this sound like dirty or oxidized switch contacts (usually called wipers in a rotary switch).
    You can try to operate the dials quickly and hope the friction will clean the switch contacts. If that does not work a professional cleaning is in order. Yes, I know there are switch cleaning products, but I am not a big fan of spraying them in cameras.
     
  3. I have an F5 and this is a the first time I heard of the problem. Do this. Make a mark on the dial where it stopped working and see if it stops everytime at the same mark.
    The dial probably uses an optical disc to generate pulses for the steps. At some position of the dial it simply not working. The clicks are added mechanically so it won't affect the operation. The camera counting the pulse so it doesn't matter where the shutter speed or aperture is at when the problem happens.
     
  4. SCL

    SCL

    Although I recently sold my F5, I can honestly say that I never encountered the issue you described. I did have my camera CLA'd by Nikon when I got it though.
     
  5. My F5 is very beaten up (missing paint), but - while it's not had anything like the amount of use of my digital Nikons - I've not noticed this issue. I got mine from a dealer who might have CLA'd it, though. Hopefully it's just a cleaning issue (while I agree that the switch contacts are likely, it could be a dry joint on the counter, which would require attention from a soldering iron). Good luck.
     
  6. I removed the screws and pried up the part that houses the upper LCD and command dials, but did not completely
    remove this part due to the thin ribbon cables that link it to the body. I was able to see the underside of the rear command
    dial and it looked like new, no corrosion or dirt. I put it back together and tried what Brooks suggested by spinning the
    rear command dial rapidly numerous times, but it made no difference. As inexpensive as F5s are these days, I wonder if
    it would be worth the repair cost. The camera is still completely functional, but it is an annoyance. I do have an F6, which
    I absolutely love, but if I were to sell the F5 as is, I think it would bring down the value with this problem. I would not think
    of selling it without mentioning this issue.
     
  7. I have the exact same problem you describe. It affects only the main command dial (on the back). I've tried giving it a bit more use and burried the camera in rice to absorb any humidity it might have inside. That helped a little, I did notice that, but it's still far from perfect.
     
  8. I just want to add that I am having the same problem with my Nikon F5 a couple of years back. The front wheel is fine, it's the thumb wheel that's giving me the problem.
     
  9. The command dials on many of these (now getting older) F5's get dirty or "plastic mould" forms on the wipers and circuit board strips making contact intermittent or unpredictable. The only way I have found to revive a finicky command dial is to use a shot of electronics cleaner through the slot of the offending dial and move the dial back and forth many times. Short of complete disassembly of the dial turret to msnally clean the boards and wipers, I don't know of any other tricks for getting reliable operation back.
     

Share This Page