Nikon D3s corrupting CF cards?

Discussion in 'Nikon' started by john_davis|24, Dec 29, 2012.

  1. I've had a very strange problem come up recently and I'm wondering if anyone has any thoughts. My D3s seems to be corrupting CF cards. I need to get my D3 back from a loan and do an experiment to further isolate the problem with the D3s, but so far it seems to be the only common link.
    It began a week or two ago when I plugged a CF card into my MacPro to import the images into LR4. Some of them showed up completely black in the preview, and others that weren't black would not load a full size preview (from the card, pre-import), when I double clicked on the small thumbnail it just showed me a thumnbnail and would not zoom in to show the image large (usually you can see each image large in the import window, and toggle back and forth between the single image and the rows of thumbnails). It looked as if the NEF file was gone or unreadable and I was only able to see the jpeg thumbnail the camera records for the in camera preview. I of course freaked out a bit and safely ejected the CF card, plugged it into my macbook pro and they looked fine in LR4 on there. I just copied the images straight from the card onto the computer and made a manual backup (no LR involved). Then I moved them over to my MacPro and into LR, and the images seem to be fine.
    But recently, about half the cards I shoot are unreadable by any computer (tried 4 computers with each card). Luckily, I shoot in backup mode with my D3s and I've been lucky enough that one card has been readable by at least 1 computer. But the rest don't show up in LR, finder, or even in disc utility.
    To check for possible corruption via my card reader (a sandisk FW800 reader that's pretty old) I tried one backup card that had never been plugged into that sandisk reader, and used a different card reader, and it did not show up. So it's not the card reader. Seems like it must be the camera.
    I want to make sure it's the D3s by seeing if I can replicate the problem with my D3, before I begin resetting the camera, but wanted to see if anyone has any ideas/thoughts. It's terrifying to think that the camera is doing this.
    Thanks
     
  2. After you removed the card from the camera, and plugged into any reader or computer, you can never be shure if the camera did it. Placing already damaged card in any number of readers will not proove that the camera damaged the card.
    What you do: before removing good card from the camera, display the pictures on the camera LCD, and also via a HDMI or Video cable to any monitor or TV. If you see all pictures this way then you know that the camera did not damage the card.
    Also, use USB cable, (most likely the cable provided by Nikon with your camera), to transfer pictures from camera to a computer, without using any card reader or card slot in a computer, before removing the card from the camera. If you see all pictures then you know that the camera did not damage the card.
    Then, do your way of transfering with the readers and computers you have, and isolate which one damages your pictures.
     
  3. ShunCheung

    ShunCheung Administrator

    I have tested the D3, D3X, and D3S, but I never own any one of them. Therefore, while I have used them all and never had any image corruption issue, I didn't use them for very long. However, I have run into this issue on the D800E: http://www.photo.net/nikon-camera-forum/00akyq
    Since I first posted about it in August, I have run into this issue once or twice, including one of the last pictures I captured of my parents. Fortunately, I always use the "backup mode" so that only a few images on one memory card are corrupted; the ones on the other card are fine.
    In my case, since this happens infrequently, I haven't quite figured out the pattern yet. It could be a CF card issues, SD card issue, or simply a memory write speed issue. The D3 uses two CF cards and its file size is considerably smaller than the D800's (except for the D3X), so the situation may not be entirely the same.
    Keep in mind that apparently LightRoom only uses the embedded JPEG for preview. Therefore, an image may appear perfectly in a LightRoom preview because that JPEG is fine, but when you try to open the full NEF file for editing, you could run into problems. Now I use Adobe Bridge to check whether the NEFs are OK, and I keep both copies (from the two memory cards) for a while until I am sure that there are no corruptions. So far this problem has only happened 2, 3 times.
     
  4. i've never had an issue with my D3s and CF cards. i use Lexar Professional and SanDisk extreme cards. i always reformat in camera.
     
  5. Shun, are you saying this has happened to you two or three times with the D800E since August? About how many frames have you shot in that period? Even if it's only happened two or three times, that seems like a relatively high error rate.
     
  6. I reformat every time in the camera,and never had a problem with my D3 or myD3s. I too use the SanDisk extreme 3 cards.
     
  7. I also use only Sandisk Extreme cards, and I reformat both cards every single time I put them into the camera. I'm religious about it.
    This isn't a card issue because it's happened all of a sudden across many different cards of different ages and capacities. A 64GB card and four 16GB cards. There's really no way all those cards just started going bad all of a sudden after years of working fine. I have never had a corrupt card in my life before a couple weeks ago when half my cards stopped being readable.
     
  8. Frank,
    I'm not sure about that because even when a card has been unreadable by one of my computers, when a different computer could read the card, all the images were fine. I haven't actually lost any images so far, but I think that's just great luck on my part. I think it's likely they would all look fine if shown on the screen from my camera. It is a good idea to try though. But if I shoot all my CF cards on my D3 and have no issues, and then do the same thing with my D3s and the same thing happens again with half the cards being unreadable, it's pretty clear it's the D3s.
    Shun,
    I know LR uses the jpeg thumbnail for the preview, but when you double click on an image in the thumbnail grid in the import dialog, it shows you the image at 100%, which is not the jpeg anymore. What I have found on a couple CF cards is that with about half the images on the card, the jpeg thumbnails showed up, but LR could not generate the 100% preview when I double clicked on them. It was able to show me this 100% preview on other images on the card. And a couple times, many of the images have just been black even in the thumbnail grid. I've seen this on multiple computers. It suggests to me that for some reason, some of the NEF's were unreadable, and sometimes both the NEF and it's jpeg thumb were unreadable.
     
  9. On reading the OP, I tend to think this procedure might be your best solution:
    I just copied the images straight from the card onto the computer and made a manual backup (no LR involved).
    I noticed that Phil Harvey has recently updated his "Fix Corrupted D4/D600/D800/D800E NEF Images", but he only documents a problem with Nikon Transfer 1. That page also links to this page, which details the older software issue that was corrupting auto-rotated NEF files.
    I might also add that I usually use Nikon Transfer 2 myself for transferring the D800E files, and have run into at least 3 corrupted files from different CF and SD cards (out of 1400), which normally have no problem. Since I have a firewire CF card reader driver crash issue with NX2/Transfer2 when using Win7 now (and didn't originally), I usually use the Mac OSX 10.8.2 (on the same computer) to transfer the files to the computer without issue. IF I have any more of the corrupt file issues, I will certainly always use my suggestion above to use the native OS file system to transfer the images off the cards, rather than running them through some utility software. Actually doing so, in at least one case solved the corrupted image problem for me.
    I have never yet had the case where both the original NEF file and the backup JPG on separate cards were corrupted.
    So yes all that is to say, I think this might primarily be a software/driver/hardware issue unless your camera has changed and is causing the issue to show up with an out of spec format/write to the cards.
     
  10. I appreciate the help, but I think you may have misread or skipped over most of my post.
    No computer will even see half the cards I've shot in the last couple weeks at all. They do not show up in finder, nor does disk utility even see them. There was 1 card that showed up on my laptop but not on my macpro, or 2 other mac computers, but that is the exception, the rest were not seen by any of the 4 computers here.
    And when I have had the issue with LR only seeing the jpeg thumbnails, it has not been a few images, it has been hundreds of images- usually half the CF card. When the jpeg thumbnails have been black it has also been nearly half the CF card.
     
  11. Correct, it was not clear to me from the OP how you were moving the images off the card. It appeared on reading to me you always were always using Lightroom to effect the transfer, and not the OS directly.
    So while what you say tends to suggest this to me, out of spec format/write to the cards.
    When disks can't be read by multiple systems directly, it is usually that the media has been written in an out of spec way.
    However since we don't know the actual OS and driver/software versions, state and wear on your systems, its hard to explicitly pin this down until you can arrive at the case where it either consistently works properly or doesn't.
     
  12. I use Nikon Transfer to suck the nefs into View NX2, then I save them twice as tiff's. One goes into an external drive for badckup and another is saved and worked on using Lightroom 3. I'm moving to Capture Pro soon as I don't like the Adobe file system. I also read that its the best apart from Nikon software to read nefs.
    I also keep the CF cards in the camera and reformat them before any shoot.
     
  13. This isn't a software issue because the computer isn't even mounting the card. Capture Pro has nothing to do with this...
    I've tried 4 Macs with various versions of the latest OS. Nothing funky. My MacPro and macbook has 10.6.8, and the other 2 Macs have the most recent OS.
    I just discovered that the secondary card reader I was using is not working. I tested my D3 with 6 cards, and my FW800 reader mounted all of them, my original USB reader mounted none of them, and a second USB reader I found here mounted all of them.

    I need to do more testing, but it looks like I may have a second problem here (faulty USB reader) which is confusing the issue and lead me to think my FW800 reader was not the problem, leading me to think the D3s was the only common link.
    I just ordered another reader and will do some more tests tomorrow. Maybe I have 2 bad readers here. That would be strange but a big relief. And I'm not sure why my FW800 reader would get funky all of a sudden like this. Maybe a mouse took a crap in it.
     
  14. I'm trying to recreate the problem and the last 6 cards I've shot with my D3s (in backup mode 2cards x3 shoots) all mounted fine on my macpro (the one that's been giving me the most trouble) with both of my card readers (not using the bad USB one anymore)
    But I noticed that one 64gb card mounted as "D3" instead of "D3s" on both card readers. The rest mounted as "D3s" like they should. Is this indicative of some kind of error in the way the cards are being written? Or meaningless?
     
  15. It means the card was formatted in a D3 instead of the D3s.
     
  16. Yes, but I had just formatted it in my D3s, taken 30 pictures, removed it and put it into the card reader. No D3 involved...
    I had used it in my D3 previously for testing though, the previous card format was done in a D3 so maybe it didn't get properly formatted in the D3s. Could be a sign of a problem.
     
  17. Are you absolutely sure you formatted it in the D3s?

    Formatting the card in the camera writes the volume name with the camera model. If the previous format was in the D3, then it's more likely you lost track of formatting the card. Occasionally happens to me when I'm formatting several cards at once.

    If the camera is randomly writing bad bits, which could be the case, it's unlikely the bad bit rewrote the the volume label from D3s to D3.
     
  18. It would be nice if the comparison between the two cards could be automated. Then you could just blast two cards full of data, stick them in two different card readers, and run WinMerge (or an equivalent utility) on them.

    Unfortunately, it's not quite that easy as the "identical" files on the two cards have a couple of different bits that indicate which card slot it was in, so most simply binary comparisons will flag them as different.
     
  19. I'm sure I formatted both cards. I've been doing this awhile, it's something I religiously do everytime, and I always shoot in backup mode. I use the "2 button" method rather than going into the menus, and I watch the card icon blink until it is done... i was also being extra careful now because of all the problems.
    However, I checked the cards again and noticed the images from the previous D3 shoot are still on the card, so clearly it just didn't get formatted. Within the root "DCIM" folder there are 2 folders, one D3 and one D3s. Who knows, I'm sure I formatted both cards but I don't know why this one wasn't formatted. I have never noticed old images still on my cards before. This whole problem is getting very strange I think I may be stuck in some sort of post apocalypse twilight zone.
     
  20. Lol, I assume when you reinsert the CF card back in the camera the images show up? Also, you might check the firmware on you D3s to make sure it is up to date.
     
  21. ShunCheung

    ShunCheung Administrator

    I have about 3600 actuations on my D800E, and I usually use the "backup" mode to write to both cards. So far I have come across about 4 images that are corrupted on one side, but the ones on the other card are fine. I haven't quite figured out whether any particular memory card is causing the issue. Those are always isolated image corruptions instead of many consecutive bad ones.
    I could have missed some corruption too because as soon as I found the images were fine on one card, I would ignore the ones from the other card. Now that I realize there could be an issue, I always check all images from both cards. Unfortunately, so far I haven't figured out the cause yet. If the problem always comes from one card, I would simply stop using it.
    This was never a problem with the D800 test sample I used earlier.
     

Share This Page

1111