My X-T1 doesn't fire.

Discussion in 'Mirrorless Digital Cameras' started by vdp, Nov 12, 2018.

  1. vdp

    vdp

    This is the story: Two years ago I purchased 2 X-T2's and placed my X-T1 on consignment. It never sold, so recently I took it back and was using it on occasion. Today I took it out and it won't fire. I notice all the settings are stiff but I'M not sure that has anything to do with the camera not firing.

    Would it be worth having it fixed? Or should I consign it to the dumpster which I would hate to do since I feel a camera is a tool of creation.

    Thanks.
     
  2. Battery issues(dead, poor connection)could do it. Not sure what you mean by "stiff" settings. Any chance it took a dip? Any activity on the LCD or EVF with a charged battery?
     
  3. vdp

    vdp

    BY stiff I mean that the dials don't move as easily as they once did. The batteries are working as is the LCD and EVF . It was in the display case at the store for two years before I took it back. Perhaps something dried out in the camera. Or it may be as you said a poor connection. Thanks for responding.
     
  4. If it comes to the point where the only viable decision is to toss it in the trash, at least do a teardown video or series of photos and post it here.
     
  5. vdp

    vdp

    UPDATE: Yesterday I gave it a slap on the side and this morning I put my 27mm lens back on and low and behold it started to work again. I'll keep it around the apartment as a cat camera and sunset from the window camera. Go figure.
     
  6. I'm glad you didn't take my advice.
     

Share This Page