My silverfast cannot find plustek scanner

Discussion in 'Digital Darkroom' started by ant_nio_ferreira, Nov 24, 2012.

  1. I wonder if someone can help me: after upgrading silverfast universal version 6.6.1 to version 6.6.2 via internet with my Mac (OS version 10.4) silverfast says it cannot find my Plustek scanner, "make sure it is on and connected and asks me to refer to the SFlog file in the silverfast folder; well, my scanner is connected but I cannot find the SFlog file anywhere! Someone helps me please? Thank you in advance!
     
  2. The problem is the Silverfast driver software is either old or behaving badly. Look for a driver update from Silverfast or try to re-install the driver.
    My own Plustek 7400 scanner only finds the driver software when I switch it on *after* my PC it's attached to is on and running.
     
  3. You might need to get a new driver from Plustek.
     
  4. You might try Vuescan. I find it to work much better then Silverfast. As well as being much less expensive.
     
  5. Silverfast doesn't have drivers per se, each version of the software is brand and model specific. If you upgraded, it would be for the Plustek model scanner of the old version, it's specific in the download process through Silverfasts Website. That said, while I've upgraded both OS-X and SF, I remember under the older versions with my scanners I always had to turn on the scanner first to let it fully warm up before starting SF Universal so it found it. Just a thought, but I've found SF's support, although slow sometimes, to be good when they answer.
     
  6. Entry for confirmation/update misbehaving, not me, I just typed.
     
  7. Entry for confirmation/update misbehaving, not me, I just typed.
     
  8. Entry for confirmation/update misbehaving, not me, I just typed.
     

Share This Page