My laptop won't recognize my camera as a device

Discussion in 'Canon EOS' started by atalanta_bluff, Jan 10, 2017.

  1. Hi I recently updated my computer - I had installed EOS Utility with the software download package for my Canon EOS 700D from the canon website as I have no CD drive for the CD rom. Since this update my laptop does not recognize my camera when it is attached via USB to a USB port, I have tried it in different ports on the machine with the camera turned on. I uninstalled and re-downloaded the Canon EOS Utility software for my correct operating system and still nothing happens. When I run the EOS Utility software it just asks for the camera to be connected and although, it is the computer doesn't pick it up as a device. I have tried going into my Device Manager settings and uninstalling the camera and checking for new hardware but it does not read it at all as a device there is one 'Unknown Device' & I'm not sure if this is the canon camera or not. Please help me to find out how to get the computer to recognize my camera when it gets connected again, it used to start EOS Utility automatically when connected.
     
  2. This is not an uncommon problem. When I encountered this I chose to ignore it and use an external cardreader. I'm sure there are methods to correct this issue but sometimes it's better to use an alternative and don't bother about the problem. Earlier cameras (10D/5D - about ten years ago) had a few interface settings to choose from, I don't know if this is still the case. Have a look at the manual.
     
  3. Unfortunately a card reader is not a solution if the OP wants to tether the camera to the laptop.
    I think there's a setting that allows the camera to communicate directly with the laptop, instead of just transferring files, but I can't find it.
    <Chas>
     
  4. How did you "update" your computer? Did you upgrade to Windows 10? It would be helpful to know.
    Meanwhile, as previously noted, an external card reader is a simple workaround for this issue and should be considered if you only seek to transfer image files from your camera to the computer.
    Also, have you tried a new/different USB cable? It's possible the existing cable is no longer working properly.
     
  5. Found this at http://community.usa.canon.com/ for another Rebel model. Yours may be similar. On your camera do this:
    To enable this, first make sure that your camera is disconnected from the computer. Press the MENU button and then use the right arrow key to select the second "Tools" tab in the menu. Use the down arrow key to select the item labeled "Communication" and then press the SET button. Use the up arrow key to select "Print/PTP" and then press SET again. Press the MENU button to exit the menu system.​

    Then try reconnecting the USB cable to camera and computer.
     
  6. It might help knowing what OS you are using. If Windows 7 or 8.1 (Not sure on Windows 10) there are a couple things you can try. Before proceeding be sure your USB cable has not gone bad. It happens. If this happened after a Windows 10 upgrade from a previous version of Windows, these instructions will be of no use to you.
    • Option 1. Restore your computer to a restore point before the installed update happened.
    • Option 2. Look at the updates that were installed.
    1. Start Menu>Control Panel>Programs and Features
    2. Click on show updates.
    3. Look at updates that were recently installed on the date your update and problems happened.
    4. These updates can vary from Update for Windows (KB#########) to Security Updates and sometimes they may be for drivers, Adobe, Microsoft Software, etc. One of those updates that were installed on that date is your culprit. You can start writing down all the KB numbers and do some research (Google is helpful) and see what they did. Look for Windows Updates, Hot Key fix, USB driver update, Canon Driver Updates. It could be any update that did it.
    5. To remove individual updates, click on a particular update and select uninstall. This is just removing that update. It shouldn't break your machine. But do so at your own risk.
    6. If you fix it, you may want to turn off Windows updates on your machine. I turned mine off last September, about the time MS was pushing hard to get people to move to Windows 10. I am not suggesting Microsoft would ever intentionally put bugs out in old OS updates to break the machines to force users to move to the new OS. It is just coincidence that these types of things happen after a new OS launch. But if you do turn them off, I would recommend keeping a decent computer security program (Anti-Virus, Fire Wall) running.
    If you Google recent windows update stopped my computer from seeing my Canon Camera, you may find a discussion going on somewhere that talks about the issue. Check out the Canon Camera Support site forums also.
    Good luck.
     
  7. You're welcome.
     

Share This Page