More Info on the 70-300 f4-5.6 IS USM lens Recall, Maybe

Discussion in 'Canon EOS' started by chuck_c_charlottenc_, Jul 19, 2006.

  1. I sent my Canon 70-300mm IS USM lens into Canon Factory Service on Friday
    7/14/2006 and it arrived there yesterday. I have not heard anything yet about
    the repair yet, and didn't expect to this early.

    But, I was browsing the FM Forum about this problem and found a post there
    from another 70-300 IS ownwer.

    Here it is!

    _____________________________________________________________________________

    70-300IS Portrait Mode Repairs
    As you're probably aware, the 70-300mm IS USM has a Service Notice from Canon
    for the soft photos in portrait mode. I've always thought mine wasn't as bad
    (I thought it may have been technique). While mine isn't as bad as some of the
    ones I've seen, It was painfully noticable during an airshow this weekend and
    I had a bunch of unusable photos, so I called Canon today. At first the rep
    thought I would have to send it in, but then he put me on hold to check a new
    memo he got about it recently. After 10 minutes on hold he informed me that
    they currently have no fix or replacements, and I can expect a call from a
    Canon rep within a few days. I know for a while there canon was sending out
    notices to have it repaired.
    Has anyone had their replace/repaired, or have any other news/updates on the
    subject?

    Brian Skibinski

    Canon EOS 20D

    EF-S 18-55, EF 70-300 IS USM, Tamrom 28-75 XR Di LD Aspherical, Sigma EF-500
    DG Super Flash, EF 50mm f/1.8 II, 100mm f/2.8 macro


    Jul 18, 2006 at 04:02 PM

    _____________________________________________________________________________


    About half way through the post there's two sentences that are very
    interesting. They are:

    "At first the rep thought I would have to send it in, but then he put me on
    hold to check a new memo he got about it recently. After 10 minutes on hold he
    informed me that they currently have no fix or replacements, and I can expect
    a call from a Canon rep within a few days."

    So, what's interesting is that I just talked to my Service Rep at Canon just
    this morning (7-19-2006) and he mentioned nothing of a "new memo" and he also
    did not tell me "that they currently have no fix or replacements"

    And as you can see, the post was at "Jul 18, 2006 at 04:02 PM" , so I talked
    to my Service Rep more than 20 hours later.

    I have no idea what's going on, but I will be calling my Service Rep tomorrow
    and I will hopefully get exactly what is going on.

    Maybe the FM Forum post is a hoax... but I doubt it. Maybe all of Canon's
    Service Reps are not being informed or they're not checking their "Important
    Mail".

    I don't know... but I will keep you up to date on my experience with process.

    //Chuck
     
  2. I'm still thinking... This just may be a misunderstanding in the conversation between Brian and his Factory Service Rep. Maybe there is nothing new at all, and that Canon is just continuing to hold shipments and that this was Brianメs misunderstanding? But, then again, when I called about a month ago, my Service Rep directly said that he would call back and give me the instructions when they were ready for my lens to be sent in... and he called three weeks later.

    Of course, Iメm sure that Canon doesnメt want all these lenses at once.

    The reason I don't necessarily believe Brian's post now is that it just seems strange to me that Canon would have me send in my lens and then all of a sudden the fix they had planned for it is now "No Longer Valid".

    Hopefully, I will have the answer tomorrow and I'll be sure to post it.

    //Chuck
     
  3. Oh, there is a fix and it is getting done:
    http://forums.dpreview.com/forums/read.asp?forum=1029&message=19261803

    I figure when you have an organization as large as Canon's, it may take a while for everyone to get on the same page.

    Now, I just want them to start releasing the brand new lenses with the running change installed as I have no long lens right now.

    Brian
     
  4. Direct from Canon's website

    http://www.usa.canon.com/consumer/controller?act=PgComSmModDisplayAct&fcategoryid=216&modelid=11922&keycode=2112&id=28468
     
  5. Brian,

    I've known about the Service Notice. I was wondering if Canon had re-directed their plan on fixing this lens since the Service Notice was issued.

    //Chuck
     

Share This Page