Mamiya C22 Repair Attempt

Discussion in 'Classic Manual Cameras' started by thomascallahan, Feb 17, 2020.

  1. Hi all,

    I've had a Mamiya C22 for about 4 years now, but unfortunately I've never been able to use it. It was working fine, checked at a camera store and everything, but as I was loading my first roll of film, the film advance knob jammed. I asked my local camera store what the expected repair cost would be, and their best guess was "at least $200". Now, that is way outside of my budget as far as a repair goes, especially when I could buy a new C22 body for about the same price if not less, so I put it out of my mind for a while.

    Now though, a few years later, I've really got an urge to shoot square format. I figured, why not try to repair it myself? After all, I got the camera for free from a family friend, if I'm going to try a repair on any camera, it's gonna be this one.

    [​IMG]

    I tried to find any kind of guide, but it seems the C22 is not a popular model. To get into the body, I followed a guide for a Mamiya C33, but the screws were in slightly different places, as expected. Still, I was able to gently peel back the siding and remove the screws painlessly. However, I've encountered a big problem: I can't remove the metal side plate because I can't figure out how to remove the advance knob itself.

    Here's some photos of the progress I've made and the knob that's impeding my progress. There's a hole in the knob under the rubber/leatherette, but there doesn't seem to be a screw inside. Can't tell how it's attached:

    [​IMG]

    [​IMG]

    [​IMG]

    Any advice would be appreciated, even if it's just general repair/cleaning advice!
     
  2. Have you tried gripping the keyed spool fitting on the other end of the wind knob shaft and turning it counter clockwise ? If it screws off, the knob and shaft might pull out
     
  3. I have tried, but with no luck. Either it's screwed on very tight or there's something else affixing it.
     
  4. Does that hole look like it has a tapered metal dowel pin in it ? A special tool is normally needed to remove camera dowel pins.


    Read this link before you go any further, it may be of assistance.

    Link .... Mamiya C220 advance film problems
     
  5. That is very useful info, but my problem is that I can't even load a roll because the film advance knob won't move at all, regardless of exposure state.
     
  6. Is this addressed at all in the C33? It might be worthwhile to see how the others approach this.. ie Yashica or Rolleiflex? It might at least get you approaching it differently.... I guess if this is the advance.. it needs to have a wind till it registers the first frame, thereafter frame counts/measures the travel distance and the exposures. Are there Dbl exposure interlocks? Check the manual on the loading. Typically Roll film cameras have "free wind" until the register point. When the back closes it's the signal to start measuring. Somehow either firing the shutter or some other gesture should release the frame to be able to advance. Good Luck!!
     
    Last edited: Feb 19, 2020

Share This Page

1111