Mamiya 7II malfunction?

Discussion in 'Medium Format' started by p_c|10, Mar 28, 2015.

  1. I’ve purchased a used Mamiya 7II on eBay.
    Despite using a fresh battery, there are no lights showing in the viewfinder when I run the battery check (page 9 of the manual). Nor am I able to release the shutter per the camera function test (page 14.) Although a red warning light is supposed to appear if the shutter isn’t tripped, that doesn’t happen.
    The lens is mounted properly and the dark slide is in the open position. I'm assuming the viewfinder should display a light even without film in the camera. Am I doing something wrong or should I return the camera?
    Thanks in advance for any help the readers of this forum might provide.
     
  2. I would try to get your money back, as it sounds like you need repair.
     
  3. Thanks, Peter. I put a roll of film in the camera and had the same problems.
     
  4. Sounds like a broken main board to me. I had it replaced 15 years ago, but I can't remember how much I paid for it. If you're living in the US, I'm afraid they'll empty your pockets to the bottom.
     
  5. Hello PC
    A few things come up to my mind.
    Assuming you hear the click when you turn the camera from the off to the on position, I would first double check that the battery is of the right voltage - there are a few options of batteries you can use, including small cells layered one on top of the other, as per the company's indications, but the only one that really does the job is the L28 and it has to have 6vlts, although it says that you can go with a lower voltage solution. On top of that, the problem could also be that the battery lid's metal slide does not touch the battery tip. I would also want to see how the camera behaves on multiple exposure mode, just to be safe it's not some other problem. Other than that, I would also, if within the terms, try and get my money back from the ebay seller, especially if it was sold as fully functional. Let us know!
     
  6. Hello Pietro,
    I'm using a 6 volt Energizer A544 alkaline battery, a replacement for the 4LR44 battery specified in the Mamiya 7 manual. I've switched between two A544s just to ensure one wasn't bad. I'll look for a L28 lithium battery and see if that makes a difference.
    I do hear a mechanical click when I turn the camera from the off to the on position. However, the shutter does not release in multi-exposure mode.
    Thanks for your suggestions.
    PC
     
  7. I own one, and the "On" / "Off" position of the switch (white? / red?) has fooled me so many times I can't count. You may wish to triple check that.
     
  8. I suggest trying a different brand of battery. There are small differences in the battery sizes even though they are supposedly identical. I had a problem several years ago when I was fortunate enough to be living near the Mamiya repair place in Tokyo. Even though the camera was then reasonably new, they simply replaced the battery cap with a different one and I have never had a problem since then. Obviously the repair folks new that the original battery cap was not compatible with all battery designs.
     
  9. Thanks you, Geoffrey. Your suggestion is right on. I tried a different brand of battery (Radio Shack rather than Energizer) and that solved the problem.
     

Share This Page

1111