M8 stuck when formatting card -HELP HELP

Discussion in 'Leica and Rangefinders' started by herve_laurent, Sep 22, 2007.

  1. Hello everyone
    I finally made the jump and bought the leica M8 for a big phototrip to China
    Next week. I had made a few pics n the last few days and was impressed with the results
    Upon downloading my card to my Epson P-5000 but when I tried to put a new card in,
    HUGE PROBLEM. The camera can?t format the card. When you say yes to format the card the light keeps
    blinking and blinking but nothing is done. Even turning the camera OFF does not stop the process the
    formatting. I try remove the battery and start again. Same thing happens every time. I tried all my SD cards
    (since the one I first tried was brand new)
    Nothing doing. Did anyone experience a similar problem. ??
    Can someone Help ???
    Thanks
     
  2. There have been very many similar problems reported with the M8.

    Contact the store where you bought it and demand a replacement.
     
  3. Herve,

    check what version of the firmware you have on the camera for starters.

    Gonna have to agree w/ Tony that you may want to take the camera back. Another thing to try, is a another vendor sd card.

    i wish I could be of more help
     
  4. I suggest you should reformat your SD card on your PC, use FAT instead of FAT32, then insert the card onto your M8 and see if it works, if it fail, return your camera to the store you purchase for a replacement.
     
  5. Hi Herve you don't say what size card you are trying to format. The M8 will not recognize an SD card larger than 4gb and will not recognize some 4gb cards. Refer to the Leica website for complete info on SD card compatibility with the M8.
     
  6. SHOOT, SHOOT
    Thank you all so much , you found what was wrong. I was fooled by the Review on the M8
    which mentions in one of the chart that the M8 takes the SDHC when it fact it does not.

    It sucks because I just spend 250 In 4 new cards for my trip to China with the M8 and they
    are all SDHC. My pentax K10d takes them , the point and shoot Ricoh GX100 takes SDHC
    also but this $4,900 camera DOES NOT. Frustrating

    Do you think I should try to re-sell those cards or is there any chances that this can be
    changed in asoftware update ?

    Again Thank you all for your input
    Harold
     
  7. I had the same problem formatting 4GB Lexar SDHC cards. Fortuntely I have a couple of 2GB
    Lexar cards that work just fine. I guess my 4GB cards will have to wait for a future firmware
    upgrade. Meanwhile the SDHC cards work just fine in my little Canon SD800. Go figure.
     
  8. This is an issue for all makers, my canon 10D wouldn't take anything above 2Gb (well it could take 4Gb CF cards, some of the time sort of ..., the problem was above 2Gb you "might" lose data"). For you best value you might want to just go with more "slower" cards, I very seldom find the need for very high speed cards, currently using the 2 down from the top in (Xtreme II's) in my 5D.
     

Share This Page