Lightroom Classic 11.1 crashes on start up

Discussion in 'Digital Darkroom' started by stevenseelig, Dec 26, 2021.

  1. iMac (Retina Display 5K) 2017 running 11.6.1. Lightroom Classic 11.1 was just installed and it crashes upon start up. I downgraded to 11.01 and it seems to work fine. Did a backup of the catalog, restarted the computer, reinstalled Lightroom Classic 11.1, restarted the computer and it opens and seemed to work for a couple of days. Then this morning it crashes on start up again.

    Downgraded to 11.01 and it seems stable again.

    Anyone experience this problem and do you have solutions?

    Thanks
    Steven Seelig
     
  2. digitaldog

    digitaldog Andrew Rodney

  3. Found this and it does work from October
    https://helpx.adobe.com/lightroom-classic/kb/known-issues.html

    scroll down to 'Unexpected Error Opening Catalog'

    ...but not a satisfy answer. Changing preference does not explained why I had a problem, did a reinstall and it worked for a couple of days, and then quit working again....

    anyone else seeing this bug?

    unexpected error.jpg
     
  4. digitaldog

    digitaldog Andrew Rodney

  5. Thanks Andrew...just posted over there as well....we will see what happens....
     
  6. Some follow up.......these are notes that I took along with way of this odyssey, but the final observation is there seems to be an adverse interaction between playing music through airplay to HomePod minis and LR 11.1 opening probably. And perhaps this is an issue during the initial installation of 11.1, but don't know that for sure.
    So resetting preferences did not work in the most straightforward way.
    1. Working in 11.01 without a problem
    2. Made a copy of the file com.adobe.LightroomClassicCC7.plist (located in folder /Users/[user name]/Library/Preferences/)
    3. Moved copy to an external drive and deleted the copy in the preferences fold
    I did those steps just in case things did not work out with changing preferences.

    4. Then upgraded to 11.1
    1. Updated preferences using the Shift + Option keys
    2. Lightroom opened without my old preferences (to be expected)
    3. Closed LR and it crashed on closing asking me to send an error report to Adobe…which I did
    4. Did this several times and it always crashed
    So
    1. I down graded to 11.01
    2. Opened LR with the Shift +Option key to force a new preference file in 11.01
    3. LR opened without my old preferences as expected
    4. Closed LR without a crash.
    5. Opened and closed without a problem several times
    so
    1. Installed 11.1 again
    2. Nothing happened (icon on dock with bounce for a few times and then stop without windows opening)
    3. Opened LR with the Shift + Option key to install 11.1 preferences
    4. Tried to open LR and still did not open..just a brief bouncing icon
    so

    Rebooted computer, but had to force quit the Apple Music App to complete reboot process

    18. Opened LR after reboot and it opened without my old preferences. Open and closed several times and it seemed to work

    19. Opened Music App

    20. Opened LR and got the brief bouncing icon on the dock and then nothing

    21. Closed the Music App, but had to force quit it

    22. Opened LR and it opened properly. Did this several times and it seemed to work

    23. While LR was open, reopened the Music App and it spent a very long time loading the library

    24. In the meantime, I updated my LR preferences and finally the Music app loaded its library

    25. With the Music App open and playing music, quit LR

    26. Tried to reopen LR and nothing happened. No bouncing icon or anything

    27. Quit the Music App

    28. Tried to reopen LR after Music App was closed and it opened with my updated preferences. Closed and open LR several times without problems

    29 With LR open, opened the Music app (no music playing)

    30. Closed LR and re-opened LR several times and it seemed to work (Music app open, but not playing music)

    31. With LR closed, started playing music on the Music App via airplay 2 to Homepod Minis. With music playing, LR refused to open)

    31. Stop playing music in the Music App and LR still refused to open

    32. Quit Apple Music

    33. Opened LR and got an error message saying something about the windows and given an option to reopen the windows. Selected reopen the windows and LR seemed to open properly.

    34. Closed LR and reopened it several times without additional errors. , but Apple Music was closed

    35. Opened Apple Music but NO music playing

    36. Opened and closed LR several times without problems.

    I have now replicated this process and the following appears to be the case.

    If Apple Music is open AND playing music, LR will not open

    If Apple Music is open, AND HAS NOT PLAYED music, LR will open

    If Apple Music has been opened and played music even briefly and then stopped, LR will start to open and then close
    1. Opened Pandora and played music through iMac. LR opened and closed successfully several times
    2. Switched Pandora to play through Airplay to Homepod Mini’s. LR fails to open and on second try get a message that says “The last time you opened Lightroom Classic, it unexpectedly quit while reopening windows. Do you to try to reopen its windows again.” Selected ReOpen option and and LR closes
    3. Switch Pandora to play through iMac, got the same error message as above, but then LR opened properly.
    4. Opened and closed LR several additional times without errors
    Went back to Apple Music and played music through the iMac. LR opened and closed several times without problems.

    With LR open, switch Apple Music to airplay 2 to Homepod minis (stereo pair)

    Closed LR, reopened and it failed to open. On a second try, got the same error message “The last time you opened…), upon selecting ‘ReOpen’, LR closes. A third try a repeat LR fails to open with the same error message

    Closed the Music App, and upon reopened LR get the same error message, but selecting the ‘Reopen’, LR opens properly.

    SO on further exploration it seems like it is related to any music app playing through airplay and somehow that interferes with LR opening properly.
     
  7. digitaldog

    digitaldog Andrew Rodney

    Try logging into another account (you may need to make one): does it still crash?
    If you boot into Safe mode (hold down Shift Key at boot): does it still crash?
    Have you tried running a free utility like Onyx to see if that stops the crashing?
    https://www.titanium-software.fr/en/onyx.html
     
  8. If I log into another account on my computer, I need to register both Apple Music and Lightroom Adobe Account. Do you know whether those will count against my allowed accounts for Adobe and/o Apple?
     
  9. digitaldog

    digitaldog Andrew Rodney

    Logging into another account on your Mac should't do this with an Adobe app.
    FWIW, with an Adobe subscription, you can have any number of machines access CC, but only two at a time, so you can log in and out of as many as you need, up to two per CC account.
     
  10. What about the Music app?

    Also, opening in safe mode does NOT allow me to use Airplay in the Music App. I would to spend some time figuring out what that is the case, but as before, with the Music App open, but NOT playing, LR does open properly, just as it did in the 'non-safe' mode
     
  11. digitaldog

    digitaldog Andrew Rodney

    I don't think there is any restrictions on Apple Music, it's all going through your iCoud account. But if it's conficting with Lightroom Classic, well there's your answer; stop using the two at the same time.
    FWIW, on this end, I can have LR and Apple Music going without any issues.
     
  12. But are you playing through Airplay 2. I can use LR and Apple Music and Pandora as long as they are going to the computer. But as soon as I link either app to an AirPod Mini speaker (in my case a stereo pair), LR fails to open. This is similar to another user's experience on Adobe community page.

    And another answer is to just use my iPad or iPhone to play music to the Homepod mini's, but I really don't unresolved bugs because they eventually will come back and bite you harder! lol
     
    Last edited: Dec 28, 2021
  13. digitaldog

    digitaldog Andrew Rodney

    I am not using Airplay. I could test this. But it's unnecessary for me; editing in LR is. Maybe someone on the Adobe forums will say they too have this issue. But the likelihood it is one, an Adobe bug and two, it's associated with Airplay and get fixed is low. It's as likely an Airplay bug.
    I am on 12.1 OS FWIW.
     
  14. It would be a simple test if you have any Homepod's. Open Apple Music and stream via Airplay to a HomePod or HomePod mini. Then try to open Lightroom and see what happens.

    After the test, quit streaming with Airplay, close the Music app and then try to open LR. I have done this 10 times today and it always seem reversible but simply turning off the Airplay and closing the music app.

    I am on OS 11.6.1
     
  15. digitaldog

    digitaldog Andrew Rodney

    I don't have Homepods.
     
  16. Any airplay speakers?
     
  17. digitaldog

    digitaldog Andrew Rodney

  18. thanks....hopefully Adobe will fix this bug...have a great New Year
     
  19. Strange problem. I listen to music with bluetooth earphones or a bluetooth speaker and work in LR with no issues. Don't use HomePods. Have you looked on the Apple website forums?
     
  20. digitaldog

    digitaldog Andrew Rodney

Share This Page

1111