Incorrect renaming of files by Lightroom

Discussion in 'Digital Darkroom' started by ksporry, Jun 22, 2015.

  1. Question:
    Today I tried exporting 3 files from Lightroom CC, with a rule to be rename the files "custom name - original file name". The first of the three in the batch was renamed correctly during export. The other two were not renamed in accordance with that rule. Why is that? What could cause that?
    Note: When I hover the mouse pointer over the file in Lightroom, or select the file in LR, the original filename shows up normally, so it's not that the file is named differently.
    Note2: The way I worked these files is: First basics in Lightroom CC, then change to PS for additional work, then get them back into LR for final touches, followed by an export.
     
  2. Did you export them all as a batch or each image individually? I have used F2 to rename a batch of images in LR before and had one of the images fail to rename. Similar thing has occurred when batch moving files, with one refusing to move. I doesn't happen often and I have never been able to work out why. I assume it must be a temporary permissions issue with the file. It always moves/renames when I retry.
     
  3. I exported a batch of 3 images at the same time. Mine wasn't temporary as I tried re-exporting several times, with the exact same result. I didn't have this problem before. I'm suspecting it may be because of a renaming in PS after editing them in PS. Basically, although the all three were edited in PS, only 2 of those got renamed (suffix "-PS") when I saved them in PS, and added them back into LR. The one that wasn't renamed exported correctly. The other two did not.
     
  4. It will not rename a file if there is already one with that name in the folder. For example, it has been rejected and is sitting there, invisible to you in the current view. This can look as though it is refusing to rename a file. The answer is to delete or move the rejected file somewhere else.
     

Share This Page