Impossible film NOT ejecting right out of Spectra

Discussion in 'Extreme, Retro, Instant and More' started by vernon_jenewein, Mar 13, 2016.

  1. I have 2 Spectra cameras. One a Polaroid Spectra 1200si and the other a Minolta Instant Pro (same as the Spectra
    Pro). In a recent purchase of Impossible films I have had difficulty with the picture ejecting after the shot
    (shutter, whir eject) . Is this an issue with all the Impossible films? Manufacture date of the one I had
    issues with in the Minolta was 8/15 Other one that was intermittent eject issues is 4/15 manufacture date. Even
    the Polaroid Spectra 1200si is having issues with sometimes ejecting the film.

    Other thing I noticed on these pictures is lack of any "vibrant" colors. They reminded me more of B&W film, with
    a pink cast than true color films. You should see how they look against my Polaroid 450 and Fujifilm FP-100c
    film. That film is fully vibrant in color compared to this.

    Perhaps it was wishful to think that I could get results like I did with my earlier Kodak EK4. If I remember
    right, even the earlier Polaroid Spectra and SX-70, etc cameras, with their respective films, did a whole lot
    better than does the Impossible films.

    What happened? Were the original Polaroid chemistry too toxic, banned, unstable.

    BTW I also have that Impossible Frog Tongue that covers the picture "when" it ejects.

    Vern
     
  2. Back on the ejection. I have SOLVED that issue. And, I have found out what is causing it. In the exit end of the film pack is a small mylar plastic "curtain" that keeps the film from light exposure if the door is opened. On this pack of film it was somewhat "deformed" and presented a clear blockage for film to easily leave the film pack.

    How I fixed it: I was working with already wasted film, so I tried many times to get the film to exit after an exposure. I could hear the shutter, and whirring, but no film/picture exited. Even with my finger pressing the film to exit, it was a definite stop at that film cartridge exit. So I took one of my single edged razor blades from my shaving kit and cut the Mylar plastic curtain out completely. Then I loaded back up the film (using 5 old no good exposed film) and the dark slide. Out came the dark slide, and I shut the flash off on the Minolta after that to save battery. Clicked the shutter and out came the first picture. Second click and out came the second pictures, and so on. Then I re-loaded the pack all over and did it again with success.... 3 times! No issues with film ejecting.

    Vern
     
  3. This is why I have stayed away from the new instant films. If or when they can do it better I will spend some money and give it a try.
    Think about it: If Polaroid tried to market a film like this, they would have folded in the 1970s.
    The SX-70 technology doesn't attract me that much anywayas I am more interested in 4x5 format photography. those "Impossible Project" films have problems too I hear.
    even if they ever do get it right (and I really hope that they do) I can't see using large format peel apart instant film for anything ("scouting a location, proofing a composition or exposure etc)—as long as it costs MORE than the already expensive sheet films.
     

Share This Page