How do I get my Canon 400D off the bulb setting which is stuck on?

Discussion in 'Canon EOS' started by rachel_prosper, May 12, 2010.

  1. I am desperate to find someone who may know how my camera became stuck on bulb whilst on the manual setting and how to rectify the problem. I was taking candlelit photos and the shutter speed changed from 30 secs to bulb automatically. Now it won't change back to any other shutter speed whilst on the manual setting. I am hoping I can correct this without taking it back to the shop! HELP!
  2. Have you tried taking out both batteries for a few minutes then restart to see if that helps?
  3. Yes I have taken the battery pack out for a few minutes but it is still stuck on bulb. Any other ideas? I am borrowing the camera at the moment for a uni assignment and I really need to use the manual function but with a fast shutter speed - not bulb! This is so frustrating!
  4. In manual 'M' the shutter speed is adjusted by turning the wheel near the shutter button. It is easy, while adjusting the aperture, to accidently set 'bulb' (by momentarily releasing pressure on the Av button). The camera should move off this setting by turning the wheel to the right. If this doesn't work then the camera has a fault and a reset is the first thing to try. As David mentioned there are two batteries that need to be removed for a complete reset. Page 155 of the manual describes how to remove the second date/time battery. My 400D has frozen a few times in the past, but generally came back to life after turning off for a period, and only once did I need to remove the main battery. I haven't had to remove the date/time battery yet. There are capacitators in the electronics, the batteries need to be left out for a few minutes until these have discharged.
    What happens when you go to Av or Tv?
  5. When you turn the dial in M mode, nothing happens? That is the only way to change shutter speed in M mode as far as I can tell. If that isn't working, you probably need to take it in.
  6. Thanks for all your help guys! You were right David and Neill, I did need to take out both batteries for a complete reset! I wasn't even aware that there was a second date/time battery as I hadn't got that far in the manual and it isn't my camera. Problem is solved and I can get on with my uni assignment! Yay! This is my first time using a public forum and I will certainly be using it again for future dramas... thanks again!
  7. Sorry for getting your name wrong Keith. Glad we were abkle to help Rachel.

Share This Page