Help with Mamiya RB67 Pro-S shutter release!

Discussion in 'Medium Format' started by emily_mitchell, Feb 21, 2014.

  1. I am a beginning medium format photographer and I would REALLY appreciate some help.
    I ordered an "excellent" quality Mamiya RB67 Pro-S from KEH camera. The film loaded fine. I tried to push the shutter cocking lever, but it wouldn't budge. It was pointing upwards (towards the ceiling), but I figured that since it wouldn't move that meant that the shutter was cocked. I pushed the shutter release button, and -- success!

    The problem started when I moved the shutter cocking lever, to re-cock the shutter for my next shot. It moved this time, so that it rested along the focusing knob (pointing outwards, away from me). Once it got to that point, it wouldn't budge again, so I figured that the shutter was once again cocked and ready to go.

    But when I pushed on the shutter release button, it wouldn't release! The button "pushes" in, but I don't hear the shutter sound and I can tell no picture has been taken.
    Here are the things I made sure of:
    1. My shutter is cocked (since I pressed the lever)
    2. My film is advanced (the little #2 is all white, no red)
    3. The dark slide is out
    4. The shutter safety mechanism (the "release ring") is turned so that it is pointing towards the white dot
    I have NO idea what I have done wrong, and I don't know a soul who shoots these cameras, so I would REALLY appreciate anyone who can take the time to help me. Thank you!!
     
  2. The user manual, split into 2 pdf files, is here:
    http://www.butkus.org/chinon/mamiya/mamiya_rb67_pro-s/mamiya_rb67_pro_s.htm
    Is the lens mount ring fully locked?
    Is the A/M switch on the lens at A?
     
  3. The shutter cocking lever should return to the up position after you cock the shutter. Can you push the lever down a little more? (Don't force it.)
     
  4. "Is the A/M switch on the lens at A?"​
    maybe A is N on some lenses, so its a N/M switch
     
  5. "Is the A/M switch on the lens at A?"
    What A/M switch? This is an RB67 whose lenses don't have these. M645 lenses do.
    Check your lens, Emily. Can you release and cock the lens shutter when its off the body? Sounds like the lens and body aren't communicating or there's something wonky with the shutter cocking mechanism. You might also make sure the back is correctly seated(both top and bottom back slider buttons in there correct positions?); and also check the pins protruding from the RB adapter to make sure they're contacting the release points in the film back. These are part of the double exposure lock-out feature on the Pro S.
     
  6. RB67 lenses do have the A/M mirror lock-up switches.
     
  7. However, I don't think that switch is the problem. Emily said that the shutter cocking lever was stuck in the down position. It did not return to the up position. Re-read her post.
     
  8. The "dark slide is out" .. but is the pin stuck in the "depressed position?" ... sort of guessing as there are so many safety interlocks on this camera .. and I don't shoot it much anymore ..but a few years ago I took my Pro-S to have it serviced and found that the cocking lever springs in the camera body were broken .. springs replaced and it works like new ..
    sounds to me like the cocking lever itself is the problem .. but you'll have to have a camera tech open it up and look into it .. may sound strange, but these cameras are very well built and problems easily corrected .. my technician (probably long retired now) took me into the shop and showed me the camera completely disassembled .. my camera was purchased second-hand and to our surprise the previous owner had cannabilized one of two cocking lever return springs .. can't tell you how many rolls of film I shot with only one of two return springs working .. but the camera worked perfectly until I broke the only remaining cocking lever spring.
    Technician put in another spring .. his cost about $2 at that time and charged me $100 for labor and to clean and lube up the camera and check the shutter speeds .. it now works like new. KEH should be able to help you get it back in operation or perhaps trade the camera .. depending on how long ago you made your purchase .. but don't give up on it .. it most likely is easily fixed.
     
  9. Agree that it's probably an easy fix if indeed something's come adrift. I've fixed a few minor glitches on my Pro S, RB adapter and Pro S backs. Send it back if you can't sort it.
    "RB67 lenses do have the A/M mirror lock-up switches."
    Sorry but the RB67 lenses' MLU switch doesn't function that way. It simply splits the mirror/baffle up+leaf shutter release process into two separate functions, the first triggered by the MLU with a cable release and the second, the leaf shutter in the lens, by the usual shutter release--point behind the Mamiya RB67 two-ended cable release. The stop down lever on the lenses is spring-loaded and only temporarily stops the lenses down to shooting aperture to check DOF. The Mamiya 645 lenses do have an A/M slider that works the way you think since the bodies use a focal plane shutter and a MLU switch on the body.
     
  10. The Pro S I had was froze up when I purchased it. I figured out how to disassemble the cocking drive and get the lens off the body. I found the shutter main tension spring post deformed from wear causing the problem. The shutter was not repairable. I put the body back together and found another lens. Fixed the light leaks in the roll film holder and had a good working camera.
    If the switch that splits the mirror and shutter release was not fully in one position or the other it would cause cocking problems probably due to wear in either the lens or the body.
    Mamiya wanted $1000 to fix it at the time.
     
  11. paul ron

    paul ron NYC

    Sounds like a cocked lens was mounted on an uncocked body!
    Common rookie mistake.

    All those bent parts are generally from forcing the cocking
    mechanisms... Another rookie mistake!

    The lens can be unlocked from the body by peeling the leatherete
    in the top right corner of the front standard where it has the pro-s
    logo. There is a small hole which allows you to insert a paper clip
    that will disengage the locking lever as you rotate the lens lock
    collar.
     
  12. Hello, I just got a RB67 pro-S and also having issues releasing the shutter.
    Mr. Watson quoted before: "You might also make sure the back is correctly seated(both top and bottom back slider buttons in there correct positions?); and also check the pins protruding from the RB adapter to make sure they're contacting the release points in the film back. These are part of the double exposure lock-out feature on the Pro S."
    I believe there is a problem with the interlocks from the RB adapter: if I remove it, the shutter works fine. I have tried (several times) seating the RB adapter and filmback, using another filmback and no luck...
    All these tests are being done with the dark slide removed, the double exposure prevention lever off and no film in the case.
    Please advise. Thanks!
     

Share This Page